Topic-icon open graph and joining a jom social group

Active Subscriptions:

None
HI Alex ,

Lets try this again.
I re upped my subscription and apologize for being short.

I'm trying to get the ability for Jomsocial to use open graph and post to a persons time line when they join a group.
I keep getting an invalid parameter error on the log . I have screen shots to show what I have set up so far. I read the forums and found others having the same examples and tried even commenting out the one header.php lines that were suggested in a prior post. So confused right now.

Walt

File Attachment:


File Attachment:


File Attachment:


File Attachment:


File Attachment:
The topic has been locked.
Support Specialist
5 years 2 weeks ago #57680 by alzander
First, it shouldn't be set as Explicitly Shared. Since this happens when the user clicks the "Join" button in JomSocial, and there's no notification that it will post to their timeline, it's not an explicit post. I can't see it, so also make sure that you've properly associated the action to the object.

I don't think that's the cause of the error though. Can you let us know the exact error message you're getting in the Activity Log in JFBConnect? That will help narrow things down. The setup seems correct.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
5 years 2 weeks ago #57682 by wizzard33
File Attachment:



I just get invalid parameter from Facebook

Hope this helps
The topic has been locked.
Support Specialist
5 years 2 weeks ago #57687 by mel
1. Please post pictures of the object and the action from Facebook. Specifically, open each up in your FB application > Open Graph area, scroll down to the bottom for each to the "Advanced Options" section and take screenshots of those area. A common culprit is that the namespace or the types may be wrong. Also please note that Facebook is case-sensitive for these values, so please match your objects/actions exactly as they're set in the application.

For instance, on your altconnect/groups/viewgroup/68-test page, after looking at the source, if you have your object set correctly in JFBConnect, then the value in the Advanced Options section would be
jgroup <meta property="og:type" content="allamericanthrills:jgroup">

2. Second most common culprit is the need to re-scrape your group page. If you've made any changes to the objects/actions, the Open Graph tags on the page may change (like the og:type that I mentioned in #1). Use the Facebook Open Graph Debugger , enter your URL, click Debug, then click Fetch New Scrape Information.

Try the above two suggestions/questions and we'll go from there.

-Melissa
The topic has been locked.
Active Subscriptions:

None
5 years 2 weeks ago #57690 by wizzard33
Here are the screen caps of the object and action

File Attachment:


File Attachment:
The topic has been locked.
Active Subscriptions:

None
5 years 2 weeks ago #57691 by wizzard33
Here is the result of the facebook scrape
File Attachment:
The topic has been locked.
Support Specialist
5 years 1 week ago #57695 by alzander
Alright.. we're making progress. What you show above looks good. Running an actual group URL through the Facebook Debugger provides more insight. Using:
altconnect/groups/viewgroup/45-quassy-amusement-park
The OG Debugger shows that the underlying page is really:
/index.php?option=com_community&view=groups&task=viewgroup&groupid=45&Itemid=671

If you scrape that URL, you'll get the following errors:

Object at URL 'www.allamericanthrills.com/index.php?opt...roupid=45&Itemid=671' of type 'allamericanthrills:jgroup' is invalid because the given value '/altconnect' for property 'og:see_also' could not be parsed as type 'url'.

That's the parameter error because JomSocial is incorrectly adding the following tags:
<meta property="og:see_also" content="/altconnect"/>
  <meta property="og:see_also" content="/altconnect/groups/display"/>
  <meta property="og:see_also" content="/altconnect/photos/display"/>
  <meta property="og:see_also" content="/altconnect/videos/display"/>
  <meta property="og:see_also" content="/altconnect/events/display"/>

Please follow the instructions in this thread on how to fix the issue with JomSocial.

Then, re-scrape the page in Facebook to make sure there are no more errors.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
5 years 1 week ago #57698 by wizzard33
OK, I did the edits, I'm hoping this is all correct. If somethings wrong let me know.

Thanks
File Attachment:
The topic has been locked.
Active Subscriptions:

None
5 years 1 week ago #57699 by wizzard33
Something is wrong.

I did the edits and now JomSocial won't load.

I edited it back just in case. I upgraded to the newer version of Jomsocial. Not sure if that will make a difference.
The topic has been locked.
Support Specialist
5 years 1 week ago #57702 by mel
I just made the code change to your /components/com_community/helpers/head.php. For a simpler change that the previous changes I mentioned, I just commented out lines 63 and 73, which is essentially doing the same thing to remove JomSocial from setting any Open Graph tags. I made a comment in that file that those lines were changed by us, so you don't have to remember the line numbers in case you upgrade JomSocial - we're also in the process of contacting the JS team to talk about their Open Graph tags being set incorrectly.

I then re-scraped the pages for /index.php?option=com_community&view=groups&task=viewgroup&groupid=45&Itemid=671 and altconnect/groups/viewgroup/45-quassy-amusement-park. The og:type on those pages are now "allamericanthrills:jgroup" which matches the setting in your new screenshot for the Open Graph object.

Since that seems better now, so can you try the action again please and let us know if there's any improvement?

-Melissa
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy