Topic-icon [9.0.244 Bug] Spanish language file loading

Active Subscriptions:

None
1 year 2 months ago #68514 by joomleb
Hi guys, 
PHP 7.4.33 + Joomla 4.2.9 (tested aldo on Joomla 3.10.11 with same result) + JFBConnect 9.0.215.
As far as I understand on the last packege you added an old untranslated Spanish Language file.
I noted it through the …/language/es-ES/es-ES.com_jfbconnect.ini < JFBConnect component  file.

A - Are you sure you are loading the right Spanish package ? I'm asking you because I noted that on Transifex you have the Spanish-Es-es package (the right one), but also a generic quite untranslated Spanish package

B - Normally, When a language string is not yet translated Joomla 4 should load the default English Language string, Can you confirm ?
It is not happening, I add an image here for you.
For sure, to prevent an awful result as shown above, would be better to load the not yet translated language strings in English, instead to have them as inexistent with the"; ", like for example:
; COM_JFBCONNECT_ACCOUNT_LINKED_ACCOUNTS_TITLE="Linked Accounts"
Do you agree ?

C - With Joomla 4 the Languages files should be as "com_jfbconnect.ini" and not anymore as "es-ES.com_jfbconnect.ini". Do you agree ?
Attachments:
The topic has been locked.
Support Specialist
1 year 2 months ago #68518 by mel
In reverse order...

c. Yes. However, we haven't moved over this way yet because of having an installation package compatible with both J3 and J4. This has been an issue in our tracker that I haven't gotten to yet. I have some ideas about addressing this in our installation package script, but need to look into.

b.

When a language string is not yet translated Joomla 4 should load the default English Language string, Can you confirm ?

For Joomla 3 at least, I had to add code to attempt to load the English language strings first, then the desired language file. This wasn't included behavior in J3, and I'm unsure of whether it's available in J4 now. Can you try renaming the file from es-ES.com_jfbconnect.ini to com_jfbconnect.ini to see if the default English string gets used?

a. You're right. I'm going to delete that resource.

-Melissa
The topic has been locked.
Active Subscriptions:

None
1 year 2 months ago #68519 by joomleb
Hi Mel,

C - I'll stay tuned here...

B -Tested, still the same:
I renamed es-ES.com_jfbconnect.ini to com_jfbconnect.ini = the default English strings are not used.
I renamed es-ES.com_jfbconnect.ini & en-EN.com_jfbconnect.ini to com_jfbconnect.ini = the default English strings are not used.

A - Thank You
The topic has been locked.
Support Specialist
1 year 2 months ago - 1 year 2 months ago #68522 by mel
B. So this is not the behavior that I'm seeing. On my test site, if I comment out the "COM_JFBCONNECT_ACCOUNT_LINKED_ACCOUNTS_CONNECT_PROFILE_LABEL" key, the english version gets of the string gets loaded. (See attached screenshots)

* I installed es-ES language on my J4 test site and enabled the language filter plugin.
* I added a menu item for JFBConnect account menu item page with Spanish as the language.
* I copied over the newest transifex file for es-ES.com_jfbconnect.ini into the translations folder.
* When the COM_JFBCONNECT_ACCOUNT_LINKED_ACCOUNTS_CONNECT_PROFILE_LABEL key was commented out, the English translated value was shown.
* When the key was re-enabled, the Spanish translated value was shown.
* I did not rename to com_jfconnect.ini - this behavior worked regardless of the name
Attachments:
Last edit: 1 year 2 months ago by mel.
The topic has been locked.
Active Subscriptions:

None
1 year 2 months ago #68523 by joomleb
Hi Mel.
Pease, How you commented out the language string ?
Please, Can you add that commented out file here so I can try to reply it ?
The topic has been locked.
Support Specialist
1 year 2 months ago #68526 by mel
Attached is the file. Change the .txt extension to .ini and place in /languages/es-ES folder. 

Line 13 has the string I was talking about it. To comment it out, add semicolon in the front (as it currently is). To uncomment, remove semicolon.
Attachments:
The topic has been locked.
Active Subscriptions:

None
8 months 1 week ago - 8 months 1 week ago #68664 by joomleb
Hi Mel,
still the same on PHP 7.4.33 / 8.1.22 + Joomla 4.3.4 + JFBConnect 9.0.244

With Joomla 5 release near the corner that will request at least PHP 8.1, maybe, Is the time to reconsider this releasing a "more integrated" next version leaving behind the J3 conditioning version ?

I'd like to understand the JFBConnect plan for the near future release/s...
Last edit: 8 months 1 week ago by joomleb.
The topic has been locked.
Support Specialist
8 months 1 week ago #68671 by alzander
Joomla 5 is obviously on our radar, but uptake of the new version will help dictate how it's prioritized.

Joomla 3 will not be supported in the next major release of JFBConnect.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
8 months 1 week ago #68677 by joomleb
Hi Alex,
thank you for the updating.

Please, What is (should be) the state of issues points C and B ?
www.sourcecoast.com/forums/jfbconnect-9-...e-file-loading#68519
The topic has been locked.
Support Specialist
7 months 4 weeks ago #68713 by mel
C. I'm currently working on changing the install package to remove the locale from the language filenames.

B. I think this issue will be related to C, but once I finish the installed files, I'll try to reproduce it again.
The topic has been locked.