Topic-icon Jlinked with easy social

Active Subscriptions:

None
8 years 2 months ago #38790 by plezi69
Replied by plezi69 on topic Jlinked with easy social
Hi Alex, I have done all that you mentioned and now I am getting this error
LinkedIn->retrieveTokenAccess(): bad data passed, string type is required for $token, $secret and $verifier.
The topic has been locked.
Support Specialist
8 years 2 months ago #38885 by alzander
Replied by alzander on topic Jlinked with easy social
Sorry for the delay. I'm honestly unsure what could be causing the token from being retrieved from LinkedIn. If it's happening even when the EasySocial plugin is disabled, that eliminates that plugin as the cause and means it's just something with our LinkedIn extension in general. However, it's not something we've heard of before and other users aren't reporting anything similar.

The only other things I'd recommend is:
* Disable any SEF extensions you have enabled. If something is altering or redirecting the requests from LinkedIn ti a different URL (like a 'better' SEF one), that could be preventing their data from making it to JLinked.
* Private Message me a set of super admin credentials, and we can dig further into the issue.

Thanks,
Alex
The topic has been locked.
Support Specialist
8 years 1 month ago #39841 by alzander
Replied by alzander on topic Jlinked with easy social
Sorry for the delayed response. I just saw that you had sent an email to us and your credentials via Private Message.

I was just able to get into your site to investigate further. The reason you can't authenticate with LinkedIn is because your servers time seems to be off by a few minutes. Generally, JLinked should automatically detect this and correct this problem. I'm not sure why it's not able to on your site. When I enable the "Display LinkedIn API Errors" setting in JLinked, the following message is shown on the front-end:

JLinked Notice: Server time not in sync with LinkedIn. Setting correction offset to: 78s

For some reason our correction isn't working.

The best solutions to fix this on your site would be:
* Adjust your servers time forward by 78s.
* Enable NTP on your server, which is an automatic time synchronization function that will ensure your clock never gets off by too much in the future.

Please let me know if that helps,
Alex
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy