fbpx

Given URL is not allowed by the Application configuration:

Given URL is not allowed by the Application configuration:

Hi,

I just encountered a wierd circumstance I'm not sure why this is happening. I had setup a standard authentication login process for facebook. Worked great. no issues at all. works as expected.

Then I had a user test it. They got this message:

Given URL is not allowed by the Application configuration: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

This user entered the website with the www. in front of the domain. If they remove the www. the login works fine.

I went into my setting on my app and added www. to all the domain entries. Still doesnt work. I have tried every different combination I can think of, it just will not work when the www. is used on the front of the domain.

Any ideas, have we seen this before? I did a search on the forum foe this, found one thread, but it was inconclusive.

Any help in the right direction would be greatly appreciated. I can provide admin logins as needed.

Thanks

emcguire
Eric
useravatar
Offline
8 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Given URL is not allowed by the Application configuration:

If you've followed our Facebook Application Setup Guide, you shouldn't run into this issue.

I'd recommend going into Autotune and clicking the 'Refresh' button at the top. Then, click "Save Recommended Settings". That should reset anything incorrect that you may have switched while testing.

Then, double-check that you skipped step #15 in the guide and did not set any redirection URLs in the Facebook Developer Area.

Hopefully, one of those will get you going, but if not, let us know and we can help investigate further.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24428 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Given URL is not allowed by the Application configuration:

Thanks,

After looking closely at the Setup guide, my issue (in case others have the same) was the Valid OAuth redirect URIs.  I added the appropriate URLs in that field (with and without the www. ) and it fixed the issue.

Thanks for your guideance

emcguire
Eric
useravatar
Offline
8 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Given URL is not allowed by the Application configuration:

Glad you got this resolved. Let us know if you run into anything else.

-Melissa

Want to stay up-to-date on new releases and development efforts?
Follow us on Twitter @sourcecoast and @mandreae

mel
Melissa
useravatar
Offline
3700 Posts
Website 
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11859
Total Polls:
0
Total Posts:
49712
Posts this week:
7
User Info
 
Total Users:
48457
Newest User:
DavidZX
Members Online:
2
Guests Online:
1407

Social Stream
Hide, Seek & Defuse

Handheld Electronic Game

Alex from SourceCoast is working on a new electronic game for kids called Countdown. It's a timed game of Hide & Seek with mini-games (Whack-a-Mole, Simon, etc) to complete when you find it.

Hide and Seek Toys

Before You Leave

Let us send you a 10% off coupon

For Your Next Purchase

Please enable the javascript to submit this form

No , I don't want a discount