Forum is closed

Provided og:image is not big enough

Provided og:image is not big enough

{This is not really Joomla related because it happens in both Joomla 1.5 and 2.5}

When adding an image to an article, either by an IMG tag or {SCOpenGraph image=...}, Facebook Linter cries about the image not being big enough and that it should be at least 200x200 and at most 1500x1500.
this happens also with images a lot bigger than 200x200...

[url=http://www.lighthost.co.il]אחסון ג'ומלה[/url] [url=http://www.smartmtk.com]Joomla & RTL Expert[/url]
mtk
MtK
useravatar
Offline
488 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Provided og:image is not big enough

Can you provide a link to a page where the image is larger than 200x200 and Facebook still complains? My only guess then is that JFBConnect is guessing at the right image, and choosing the wrong one (or thumbnail version of it).

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
23906 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Provided og:image is not big enough

http://www.joomla.co.il/index.php?optio … ;Itemid=91

http://www.joomla.co.il/index.php?optio … ;Itemid=89

http://www.israrg.co.il/index.php?optio … Itemid=150

[url=http://www.lighthost.co.il]אחסון ג'ומלה[/url] [url=http://www.smartmtk.com]Joomla & RTL Expert[/url]
mtk
MtK
useravatar
Offline
488 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Provided og:image is not big enough

Mtk,
I'm a bit confused about this myself. I just did a bit of testing with different images. What I found was that whenever 2 images were set, the 'image is too small' text would appear in the debugger. There are multiple bug reports in Facebook regarding the og:image property and the error your seeing:
https://developers.facebook.com/bugs/338739036234971

Facebook definitely changed things lately regarding how that's parsed, and I think that's the problem. One of the big problems people mention is if your og:image tag redirects from the URL you specify to the actual image. That isn't an issue on your site, or on our test sites though.

So, unfortunately, my only suggestions are to:
* Try removing your "default" image in the Open Graph settings area and see if that message goes away. For us it did.
* Use the bug report above and use the "Does this repro describe your issue?". Describe the problem like you did here and wait for FB to fix the issue.

Hope that helps, and thanks for the report. We'll definitely be monitoring it.
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
23906 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11548
Total Polls:
0
Total Posts:
48583
Posts today:
10
User Info
 
Total Users:
47563
Newest User:
dhotañ
Members Online:
2
Guests Online:
1033

Online: 
timwil, hancel
Social Stream
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program