Black Friday / Cyber Monday Special - 10% Off - Use "CYBER10" at checkout!

Topic-icon Select dropdown doesn't work anymore on mobile (Android)

Active Subscriptions:

None
Hi,

We are using JFB Connect for quite a while now and noticed an issue popping up recently.

The problem is the following:
After users login the select input (dropdown menu's) doesn't work properly, there still open but it's impossible tot select any option. It appears that a selection is immediately unselected.

This problem only appears on mobile, but not any mobile, and if a user isn't logged in the selectboxes work fine, so we are sure it's a login problem.
We also figured out that if we disable javascript on our phone the problem is gone to, so it's a javascript problem.

Hope somebody can help us out :)

Grtz,

Bjorn H
The topic has been locked.
Support Specialist
Can you help me understand a few things, and then we can test a lot more to help sort your issue out:
1) Does the issue only happen when you login with a social network or with normal Joomla credentials?
1a) If it happens with Joomla credentials too, can you try disabling the SCLogin module and the JFBCSystem plugin. That will disable all JFBConnect functionality. Test logging in again and see if the problem persists. If so, then the issue isn't related to JFBConnect and I'm not sure how much we'd be able to help.

2) What drop-downs are having issues? Is it the SCLogin Usermenu option to show a Joomla menu in the SCLogin module, or is it other drop-down menus?
3) What browser are you testing on mobile with, so when we do, we are testing the same way.

If there are any other details that make you think (or know) this is a problem related to JFBConnect, that will help us narrow things down quicker. From the above, I can't really tell how JFBConnect is involved, other than we allow for authentication.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
Hi Alex,

First of all thanks for your reply, I've disabled SClogin and JFBCsystem and the problem is gone!

After that I tried to only disable JFBCsystem, problem still gone. It seems the problem re-appears after enabling SC Login module.

The weird thing is, i get complaints from people with chrome browser, we have tested on other browsers like the samsung browser but it works fine there/.
I've already tried to disable jQuery within SClogin module and that doesn't do the trick either.

So hope you can help us out with this information,

Grtz,

Bjorn H
The topic has been locked.
Support Specialist
Bjorn,
So close. One last thing to test. If you're using JFBConnect and SCLogin, then you should disable the "Include jQuery / Bootstrap" setting in *JFBConnect*. When both are installed, that's the only setting we look at. It likely is that there is a conflict between the version of jQuery and/or Bootstrap that we include, but you'll really need to test to make sure all of our features continue to work after you disable that setting.

I hope that helps,
Alex
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy