Topic-icon FB Social stream - Last post not shown

Active Subscriptions:

None
Hi,

I have created a page using the Social Stream module. Just one question, is there a reason because the last post is not shown?

www.albierosrl.it/index.php/news/facebook-news
www.facebook.com/pages/Albiero-Srl/673547352763035

I did the same thing for another customer and it works fine, same module configuration, same hour of the post (yesterday at 10 a.m. my local time).

I am going to present the work to the customer and he could ask the same question about the last post.

I wish to add I'm very satisfied with your extension, it offers a lot of possibilities!

Thanks, best regards.
Francesco
The topic has been locked.
Support Specialist
6 years 9 months ago #52626 by mel
This seems to be because the latest post is sharing a link, and is not a normal status message or picture. On my test Facebook page, I just shared a link and looked at the data coming back from Facebook. There were no entries in the list for the share, just my other message. This may not be the answer you're hoping for, but it doesn't look like JFBConnect can get that message. Facebook is excluding it from the stream data that we're pulling.

-Melissa
The topic has been locked.
Active Subscriptions:

None
6 years 9 months ago #52728 by francescocurci
Hi Mel,

maybe something strange happened, in any case now it works. I did the same thing in the same facbook page (www.facebook.com/pages/Albiero-Srl/673547352763035) and now you can see it in the website stream page www.albierosrl.it/index.php/news/facebook-news
That is what I did
1) developers.facebook.com/tools/debug/og/object/ and fetch new scrape information (otherwise FB doesn't see the OG default image).
2) use my client page account to public a link of a web site.
3) upload an image (not choosing the OG image)
4) Public

I think I did the same thing in the post not shown. In any case it is not important because now with the last post it works. I hope it will continue.

Thanks for everything
Francesco
The topic has been locked.
Support Specialist
6 years 9 months ago #52731 by alzander
Francesco,
Thanks for letting us know what worked for you. Not sure why those steps are necessary, but may have just been a hiccup with Facebook in scraping your site that you fixed by using the Open Graph Debugger.

Hopefully you won't run into it again, but if you do have issues, just let us know.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
6 years 8 months ago #52874 by francescocurci
Hi Alex, now everything works very well and mu client is very satisfied.

I set an OG default image for every page, I mean one for all. I do in this way: publish a new article in the site. Copy and paste the link in FB page. Often no image is shown, probably because FB didn't scan yet the page. So I use the devolep tool to scrape the new page. After that if I paste the link the OG default image is shown and I have a chance to load a nee image. I prepare an image with this size: 640x345. For me now is a standard image with a nice background. I paste the image of the article in the site on the background using a an image editor. And that's it. I upload an image always with the right size, no matter how is the size of the image in the article in the site. It seems a long process, but the time is very well spent.

Thanks a lot
Francesco
The topic has been locked.
Support Specialist
6 years 8 months ago #52881 by mel
Sorry it's a little bit of a troublesome process, but glad you got it working. Let us know if you run into any other problems.

-Melissa
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy