Forum is closed

Help with site migration

Help with site migration

Hi,
I am in the process of rebuilding the site on top on the new template (fancy) and trying to re-enable JLinked functionality in it but it does not work. I copied all the tables from the old database (and cleaned jlinked user_map). The settings are all the same and all 3 plug-ins are enabled. When clicking on jlinked button it immedately returns with this:
Request URL:http://codistics.net/medical/index.php?option=com_jlinked&task=linkedInAuthenticate&return=L21lZGljYWwvaW5kZXgucGhw
Request Method:GET
Status Code:303 See other
Request Headersview source
Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Encoding:gzip,deflate,sdch
Accept-Language:en-US,en;q=0.8
Connection:keep-alive
Cookie:c6b237eba347c82c41ff0877bbfd2434=rbrk9ra6ikoptuvqlpubcq68p3; 3d5390dd2aa72a59823eefaf01e95751=7iviubkhhi93ej78gill059np5
Host:codistics.net
Referer:http://codistics.net/medical/index.php
User-Agent:Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.69 Safari/537.36
Query String Parametersview sourceview URL encoded
option:com_jlinked
task:linkedInAuthenticate
return:L21lZGljYWwvaW5kZXgucGhw
Response Headersview source
Connection:Keep-Alive
Content-Length:322
Content-Type:text/html; charset=utf-8
Date:Wed, 09 Oct 2013 18:38:20 GMT
Keep-Alive:timeout=5, max=97
Location:http://codistics.net/medical/index.php
Server:Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7
X-Powered-By:PHP/5.4.7


I spent hours checking everything. Any ideas / suggestions?
Thanks, Nick

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Help with site migration

Nick,
Your fancy new template has no tag for displaying standard Joomla notice/warning/error messages. I tried to login and the page simply refreshed, as you mentioned. If I then loaded the atomic template (index.php?template=atomic), the following error message appeared:

Linked API Error: OAuth callback URL was not confirmed by the LinkedIn end-point ()
From:https://api.linkedin.com/uas/oauth/requestToken?scope=r_emailaddress

Now, why you're seeing that, I'm not sure. What I'd recommend is:
* Go to the http://developer.linkedin.com/ area and check out your API settings. Specifically, make sure your Website URL is correct for the new site.
* Turn off SEF URLs and try again
* Re-install JLinked. That should update the component and plugins to make sure nothing was lost in the move.

Hopefully, one of those will get you going. I'd also recommend making sure the template is properly showing Joomla messages which can help diagnose this, and many other things.

Good luck,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24145 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Help with site migration

Tried everything. Re-installed JLinked. Regenerated the app in LinkedIn. Moved the app to the root host (codistics.net). Nothing works.
Is it normal that JLinked Overview page looks like this:
LinkedIn Application

Statistics
Total Connected Users: 0
JLinked Extension Check


Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117
Required Extensions    Installed    Available    Status
com_jlinked    2.2.0    unknown    This extension is installed and published.
mod_sclogin    3.1.0    unknown    This extension is installed and published.
authentication.jlinkedauthentication    2.1.0    unknown    This extension is installed and published.
system.jlinkedsystem    2.2.0    unknown    This extension is installed and published.
user.jlinkeduser    2.2.0    unknown    This extension is installed and published.

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Warning: Creating default object from empty value in C:\xampp\htdocs\medical\administrator\components\com_jlinked\assets\sourcecoast.php on line 117

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Help with site migration

The errors you mention above sound like one of the following issues:
* cURL is not installed or enabled on your server. cURL is what JLinked uses to make outgoing requests to LinkedIn and SourceCoast (to check for updates)
* cURL is enabled but outgoing connections are prevented on your server. This can be due to a firewall or other server configuration that is preventing these calls.

Either of the above could explain the errors on the Overview page and the issues with logging into LinkedIn.

Check your PHP configuration for cURL being enabled and/or contact your server host to make sure outgoing connections can be made.

I hope that helps get you started,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24145 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11685
Total Polls:
0
Total Posts:
49056
Posts today:
5
User Info
 
Total Users:
47818
Newest User:
normastainfo
Members Online:
0
Guests Online:
857

Online: 
There are no members online
Social Stream
SourceCoast Joomla Social Extensions
Friday, 25 May 2018
JFBConnect 8.0 Coming Soon! Stay tuned.
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program