Forum is closed

JLinked Install Problem

JLinked Install Problem

I've looked through the configuration guide, reviewed the support forum/articles, checked folder permissions...and still am getting:

        JFolder::create: Could not create directory
        Warning! Failed to move file.

Please help...

Dgbunker
useravatar
Offline
2 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: JLinked Install Problem

In the Joomla admin area, go to Help -> System Info. Then click on Directory Permissions. All directories there should show up as green. Take specific note that the Temp, Log, and Cache directories are all real directories, and also are marked as writable.

Hopefully that's all it is, but if you still have issues, just let us know!

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
23659 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: JLinked Install Problem

No, they are not writable when checking in System Info.  However, if I check the folder permissions using SmartFTP it shows 755 as the permissions level, which looks correct in some other posts I've seen.

Dgbunker
useravatar
Offline
2 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: JLinked Install Problem

Dgbunker,
That's definitely the issue then. While 755 for permissions is a good general guideline, each server is different as far as the 'owner' of files, which user is running Apache, what permissions PHP has, etc. It may be necessary for permission of 775 to install. It's even possible that you may need to make those directories 777 (fully writable by anyone) to install. If you do that, we highly recommend changing it back to a more secure mode after installation is complete.

The only other option I know if is to enable the FTP layer in the Global Configuration -> Server area. This will enable a new installation box on the Install/Uninstall screen to allow Joomla to write to your filesystem through FTP instead of directly. It's a bit roundabout, but it's been known to work.

Unfortunately, we don't have anyway of getting around those problems within our extension. If Joomla's reporting the directories are unwriteable, that means the problem is 'above' us.

Hope that helps and explains the issue!

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
23659 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11405
Total Polls:
0
Total Posts:
48071
Posts this week:
23
User Info
 
Total Users:
47240
Newest User:
lik4li
Members Online:
1
Guests Online:
919

Online: 
gibarra
Social Stream
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program