Missing OG:IMAGE tag

Missing OG:IMAGE tag

After checking forums googling and all still cant figure it out.
Evrything works beside image tag, i tried it without cache, with cache, with jfb plugin above system cache but with any of these configurations i dont get imagetag in source code, and what i wonna achieve is 1st image from article to be shown as og:image tag

Thank you for your suggestions what to do.

ijokovic
useravatar
Offline
7 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

If you're using standard Joomla articles, simple install and enable the Open Graph - Content plugin. That will automatically insert the first image in an article as the OG:image tag. With the Open Graph plugin, there's more flexibility you can have over the description and where the image is pulled from, but I don't think you'll need those features yet.

Finally, on any page that isn't setting the image how you want, you can add {SCOpenGraph image=http://yoursite.com/link-to-image.jpg} and that will tell JFBConnect the image to set as the og:image tag as well.

I hope that helps,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Online
23813 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

Allerdy tried it, but now repeated it again, the Open Graph - Content plugin is enalbed, but again there is no og:image tags in source of site, and ofc they are not working no metter what i change.
I use standard Joomla 3.0 articles . Any other suggestions?

ijokovic
useravatar
Offline
7 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

Can you post, or Private Message, a link to an article on your site where the og:image isn't being set properly? I think we need to see a page to diagnose things a little further.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Online
23813 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

The problem is in new articles Vs old articles, in old articles from old Joomla 1.5 there is og:image but there is none in new articles that are made in new Joomla 3.0
So there is still the same issue ... please assist or just tell me what should i look

article without og:image (old joomla articles)
http://bit.ly/XWdk57

article with og:image (new joomla articles)
http://bit.ly/11j4ItF

ijokovic
useravatar
Offline
7 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

Are you inserting the images into the article body the same way in both articles? The image in the 'not working'/new joomla article example is formatted differently in the HTML.

Can you check both articles in the admin area and see if there are differences in how the image is inserted into the article?

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Online
23813 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

Not sure what you mean, but using default Joomla feauture for these images of articles. Not inserting them with any WYSWYG editor or similar, 2 feautures bellow article editor for images in new Joomla 3.0 version (nothing modified)

ijokovic
useravatar
Offline
7 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

For the 'old' articles that work, are you using the 'default Joomla feauture for these images of articles'? Or were those images in those older articles inserted into the article itself?

Right now, our Open Graph - Content plugin does not support insertion of the og:image tag from the "Intro Image" or "Full Text Image" boxes. We're planning to implement that feature in an updated plugin soon. If you're using those features in the new article, for now, you'll need to add the {SCOpenGraph image=http://site.com/link-to-image.jpg} tag to the article text for things to work right now.

I hope that helps explain. I'm not sure what's different about your 'old' vs 'new' articles, but there's definitely some difference.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Online
23813 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

Hope that feauture comes soon, kinda silly to mention it's 3.0 ready when you use core feuature of 3.0 and dosn't work automaticly as it should and as it wos before in older Joomla versions.
Anyway thank you for your support

ijokovic
useravatar
Offline
7 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Missing OG:IMAGE tag

It's definitely coming soon. As for 3.0 ready, we definitely support 3.0. That means we install on it and we do support a lot of the features. There will always be features we don't support (adding Like buttons to the Contacts manager, for instance). We always implement what we know is needed, including just the functionality to make it work on Joomla 3.0, and then we listen to feedback from users.

Hope that helps explain. We're expecting the updated Open Graph - Content plugin to be out later this month. In the mean time, you can always add the {SCOpenGraph image=http://yoursite.com/link-to-image.jpg} into the body of the article to explicitly set the image. A little more work, but flexibility that JFBConnect is built on so that things we don't directly support can be easily implemented.

Best of luck,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Online
23813 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11498
Total Polls:
0
Total Posts:
48407
Posts today:
7
User Info
 
Total Users:
47470
Newest User:
robver
Members Online:
4
Guests Online:
1033

Social Stream
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program