Won't install

Won't install

Duplicate column name 'access_token' SQL=ALTER TABLE `dwc_jfbconnect_user_map` ADD COLUMN `access_token` VARCHAR(255) DEFAULT NULL;

Comes up with error 1060 and the above language.  Please advise.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

Also, it said the renewal was $48, but it charged me the entire $59.  Please advise.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

Shawn,
The upgrade/renewal discount is only valid if you renew while your subscription is still active. Your last subscription looks to have expired in January, so unfortunately, you weren't eligible for the discounted price. There is generally less support for users who keep their subscription and extension up to date, and we try to pass that savings on.

As for your issue, JFBConnect should seamlessly upgrade your database tables. The error message your reporting though is indicating there is a problem doing so. Do you know what version of JFBConnect you were using previously? You also posted in the Joomla 3.0 forums, for which JFBConnect v5.0.0 is the first release for that version. Was this a site migrated from Joomla 2.5 (or earlier), or is this a brand new site?

Any information you can tell us about your configuration just before you installed JFBConnect v5.0.0 would really help us to understand the problem and help provide a solution.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24100 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

It was installed on a new site that never had this software before, but one of our guys had attempted to install the old version before realizing it wouldn't work.  Now we cannot install the version that's supposed to work with the clean 3.03 Joomla install.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

There was an error upon attempting an earlier version; not sure if it cleaned itself up after not installing.  Perhaps not because of the error that's occurring now.  I had attempted to use the Extensions Manager to remove any remnants and retry, but it doesn't seems as if it is properly doing this as I'm still unable to get it installed.  Without the component installed the fan module, etc. will not work either.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

Without knowing what version you tried to install, I can't recreate the problem or understand what may be happening.

The solution would be to do the following though:
* Uninstall JFBConnect from the Extension Manager
* Use a database manager tool (PHPMySql or something similar) and remove the following tables from your database:
#__jfbconnect_config
#__jfbconnect_user_map
#__jfbconnect_request
#__jfbconnect_notification
Replace #__ with your database prefix.

With that, you should be back to a clean slate and installing the v5.0.0 release should work. If not, let us know any errors you get and we'll help how we can.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24100 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

Table '339331_dwc.dwc_jfbconnect_config' doesn't exist SQL=SELECT value FROM dwc_jfbconnect_config WHERE `setting` = 'db_version'

Error 1146 this time.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

When did you get that message? If that's during installation, it means that the tables weren't recreated during installation. Can you uninstall JFBConnect and try to install again? The tables being created is a part of Joomla's installer process, not JFBConnect. If they aren't being created, that's a sign of something very odd happening with your Joomla site.

After you reinstall, check out the database to see if the 4 tables I had you delete are back. If not, we'll have to figure out what's going on and why your site is behaving different than all others, as we haven't heard of this issue before.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24100 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

That was the result of following the instructions above, deleting those tables.  Everything throughout the remains of the site works fine and it's responsive and I have no issues installing or uninstalling or reinstalling anything else.  The tables haven't been re-created.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

"during installation", yes.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

Is it possible to send us super admin credentials to the site to understand what's going on? Can you tell me what was version of JFBConnect was originally installed by the other developer that started this problem?

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24100 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

sent credentials for site and DB via PM to you.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

Component remains in the list in spite of the uninstallation and tables removal from the DB manually.  Error is produced when attempting to select it.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

I'll be getting into the admin area soon to see what I can do. Again though, can you please tell me what file was installed originally? It will greatly help us to understand what may have gone wrong and speed up the debugging process.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24100 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

It was JFBConnect, the latest version before 5 for Joomla 2.5.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

Shawn,
Sorry for the issues. You should be fixed up now. I honestly don't know what was going wrong, but I just manually created the initial DB tables for JFBConnect. Then, I installed the extension like normal and it automatically upgraded the tables like it should. So, it can write to the database and do what it needs to, but something was preventing it from doing the initial install of tables.

Either way, 4.3 shouldn't have broken things that much.. so something was wrong there. The 5.0 releases have a check to make sure you're installing in the proper Joomla version though, so this definitely shouldn't happen going forward to you or anyone else.

Please test and let us know if you run into any other issues. Things looked good to me though.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24100 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

I've got it most of the way configured, but there's still something a little off.  I've used previous versions in the past and I can't seem to navigate to the part where I set the like, google plus, and linked-in buttons that I would normally set to show above an article.  For whatever reason, links are there, but I can't navigate to that section and it doesn't seem to have the horizontal layout I'm accustomed to when I click "Social" when in the component.  It's otherwise functional, but I need to set the like, linked-in, and google plus to show above the article.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

It's just not working properly, but I don't know what I'm missing or what's missing or corrupt in the database.  A number of the options I should have aren't available.  The links are seemingly there, but they're displayed vertically where they don't belong and they're not clickable.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

I got it to work by switching admin templates to Isis from Hathor.  It does not display properly or functionally in Hathor for 3.0+.

fb_564705464
Shawn
useravatar
Offline
45 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Won't install

We'll have to look into why Hathor isn't working. We definitely did our testing with Isis, but Hathor shouldn't really be a problem. Frankly, the whole admin area is in store for being overhauled.. but that won't be for another few months.

Glad you're moving though. Should you run into anything else or need more help, just let us know.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24100 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11663
Total Polls:
0
Total Posts:
48978
Posts today:
6
User Info
 
Total Users:
47791
Newest User:
alex01
Members Online:
1
Guests Online:
820

Online: 
alex01
Social Stream
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program