Topic-icon Error while trying to login with google

Active Subscriptions:

None
1 month 2 weeks ago - 1 month 2 weeks ago #68917 by hbproph
Hello, i got this error when i use google login, is there any tip my this happened recently?

TableUserMap::__construct(): Argument #1 ($db) must be of type JDatabaseDriver, JFalangDatabase given, called in /var/www/vhosts/csakamainap.info/httpdocs/libraries/src/Table/Table.php on line 343

In the server log i saw this:

GET /index.php/hu/?option=com_jfbconnect&task=authenticate.callback&provider=google&state=7735c5e677566a397d357b4abbbab654&code=4%2F0AdLIrYchkcp7wyodL0rkHf-hZRuJH5IIG-tn1c_doiWu4u6dGp_UNLqF6LjYOQt9f-NqEQ&scope=email+profile+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.profile+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email+openid&authuser=5&prompt=none HTTP/2.0

And i attached an error log sent from my security extention with full details of the error

Really appriciate your help

Update Stephane helped me out he logged in to the site and checked the issue, he responded this to me: (its a screenshot i attached here)Hi,i have try with my  live.com  account and even with the Falang database driver disabled it don't workTableUserMap::__construct(): Argument #1 ($db) must be of type JDatabaseDriver, Joomla\Database\Mysqli\MysqliDriver given, called in /var/www/vhosts/ csakamainap.info/httpdocs/libraries/src/Table/Table.php  on line 343It's not a Falang problem for me Stéphane
 
Attachments:
Last edit: 1 month 2 weeks ago by hbproph.
The topic has been locked.
Support Specialist
1 month 2 weeks ago #68919 by alzander
The error seems to be showing an issue with JFalang taking over some database operations. The libraries/src/Table/Table.php file is a core Joomla file and is expecting a parameter to be passed thats from core-Joomla to it. However, JFalangDatabase seems to be overriding the value and Joomla's not liking that at all.

I'd recommend:
* Disabling JFalang (temporarily at least) to see if things start to work
* If so, reach out to JFalang's support to see if they can help understand what is going on there.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
1 month 2 weeks ago - 1 month 2 weeks ago #68920 by hbproph
Hi Alex,

First at all really appriociate your kind help and investigation.
The thing is => I already talked with Stephane (Falang) He advised me to contact JFB first.

Really not sure where the issue coming from becasue i completely disabled Falang, tried to login with google, but has exactly the same message.

I can go back to Stephane, but are you sure that this is caused by Falang?
How can it be that with Disabled Falang i have the same issue?

Should i contact Setphane still?

Thanks for helping in this

So i disabled falang tried to login and its failed.
I got a security exception email right there attached its content, now its different
Attachments:
Last edit: 1 month 2 weeks ago by hbproph.
The topic has been locked.
Support Specialist
1 month 2 weeks ago #68921 by alzander
Your new log is helpful with Falange disabled. There's still the error but it is now Joomla related which indicates we may be doing something wrong. However, we've never seen that error before and you're the only one reporting it, which means it's not widespread.

One thing I notice is that you're using JFBConnect 9.0.244, which came out in April 2023 with Joomla 4.4. J4.4 has a lot of compatibility updates to work with Joomla 5 and we don't test older versions of JFBConnect with newer releases of Joomla, though they should work.

I see your subscription expired about 2 weeks ago... I just extended it through the end of May. Please try to update to the latest release of JFBConnect and see if that resolves the problem you're having.

Thanks!
Alex
The topic has been locked.
Active Subscriptions:

None
1 month 2 weeks ago #68922 by hbproph
Hi Alex,

Thanks a lot to start with, really appriciate your help.
My question when i go to updates available in joomla, there is nothing about jfb, so i cant update anything.

Any tip maybe what im doing wrong please?

 
The topic has been locked.
Support Specialist
1 month 2 weeks ago #68932 by alzander
I'm unsure why it's not showing as an update. We can double-check that the update files are properly posted that should 'announce' to Joomla sites what the latest version is.

In the meantime, you can download the latest version from our site by going to My Account -> My Subscriptions in the top right. You can install the latest .zip file onto your site and it will automatically update just like using the Joomla Update Manager.

As always, we recommend taking a backup of your site first to make sure you can easily revert if there are issues caused during the upgrade process.

Thanks!
Alex
The topic has been locked.
Active Subscriptions:

None
1 month 2 weeks ago #68933 by hbproph
Hi Alex,
Thats the point, i cant download anything to test, there is not option for me to download anything from your site.
Also inside my website in joomla in the extention updates menu, JFB is not there, i cant update JFB as its shows up to date.

Please see attached image, can you please help me how should i update JFB?
Attachments:
The topic has been locked.
Support Specialist
1 month 1 week ago #68936 by mel
I've updated your subscription. You should be able to login here on sourcecoast.com and navigate to My Account > My Subscriptions > Downloads to get the latest version.
The topic has been locked.
Active Subscriptions:

None
1 month 1 week ago #68937 by hbproph
Thank you very much for your kind help!
I can confirm, the issue has been solved, i have one question please:

On my login page, some login with passkey button popped up.
Do you know what i should do with it?
I cant find how to configure or disable this.
And its not doing anything even i press it.

Thanks for any info!
The topic has been locked.
Support Specialist
1 month 1 week ago #68940 by mel
Disable the Joomla 'System - WebAuthn Passwordless Login' plugin.

-Melissa
The topic has been locked.