Topic-icon JFBConnect Remote Error Check

1 month 2 weeks ago #68855 by rikbro
I just downloaded the current version of JFBConnect. When I get to the Error Check for Facebook, it fails.

"Fail: Not Detected! Please enable in the Site Config area of Autotune or in the Joomla plugin manager."

My guess is that since I don't operate Joomla on our homepage but instead operate it from a subdirectory of our site (/community), that is causing the problem.

In the Facebook Application Configuration, I've tried changing the Site URL to reflect that but that doesn't work either.

It appears to be checking only our root homepage and not the /community subdirectory.

How do I fix this?

Thanks. -- Rik 
The topic has been locked.
Support Specialist
1 month 2 weeks ago #68857 by mel
Replied by mel on topic JFBConnect Remote Error Check
That check is to look to see if the javascript initialization code is present. Looking manually at your page - yes it is present, so the error can be ignored in the meantime.

Yes it looks like you're getting the error because you're in a subdirectory. We do take the root directory and perform the error check on that value, but it should be easy to add a setting to Autotune for which directory to check. I am working on a release of JFBConnect to come out in the next few days/week so hopefully I can get that in there as well.

-Melissa
The topic has been locked.
Support Specialist
1 month 2 weeks ago #68858 by mel
Replied by mel on topic JFBConnect Remote Error Check
Can you confirm that the error check screen said checks performed on yoursite.com and not yoursite.com/community? When I test on a site I just set up in a directory, the URL checked contains the subdirectory as expected.
The topic has been locked.
1 month 2 weeks ago - 1 month 2 weeks ago #68860 by rikbro

mel wrote: Can you confirm that the error check screen said checks performed on yoursite.com and not yoursite.com/community? When I test on a site I just set up in a directory, the URL checked contains the subdirectory as expected.


 

Yes, in the Facebook Application Configuration, I had set the site URL to show the entire path: yoursite.com/community. But the Check only showed that it checked the yoursite.com/.
 
Last edit: 1 month 2 weeks ago by rikbro.
The topic has been locked.
1 month 2 weeks ago #68862 by rikbro
Looking forward to that release.

Is it possible to put my subscription on hold until then?
The topic has been locked.
Support Specialist
1 month 2 weeks ago #68863 by mel
Replied by mel on topic JFBConnect Remote Error Check
Is there any way I can get backend and FTP access to your site to put in some debugging statements to see what's going on? My test site in a subdirectory has different behavior than yours, so I'm not able to reproduce the problem. If so, please use the Contact Us button to send us the credentials.

There's not a way to pause the subscription in the store software, but I can add extra time on to your sub once I resolve the issue.

-Melissa
The topic has been locked.
1 month 2 weeks ago #68864 by rikbro
As per your message, I sent the backend and FTP credentials via the Contact Us button.

Thanks. -- Rik
The topic has been locked.
1 month 2 weeks ago - 1 month 1 week ago #68865 by rikbro
I see that you tried to login. Sorry, I forgot to assign you to Super User status. I've updated the backend so please try again.
Last edit: 1 month 1 week ago by mel.
The topic has been locked.