Topic-icon The following plugins could cause problems during the upgrade

I saw that JFBC 9.0 is compitable with Joomla 4, but just want to make sure due to this warning:  (see attachment)
Attachments:
Support Specialist
JFBConnect and the authentication, user and system plugins have been thoroughly tested for Joomla 4. Which tool is that screenshot from and are there any more descriptions/reasons for that warning?

Sendy has not been updated/tested for Joomla 4 compatibility yet, so I'm unsure whether the warnings for the Sendy system and user plugins are valid.

-Melissa
3 weeks 3 days ago - 3 weeks 3 days ago #67449 by brirem
Thank you for the quick reply.  That screen shot came from the Pre-Update Check for Joomla 4.0.3.  The update check appears when you go to Joomla Update > Options > Update Channel > Joomla Next.

I just uninstalled Sendy before upgrading to Joomla 4.0, but got Error Uninstalling Package.  Is that important?  Can I uninstall it manually: 
Warning: Package Uninstall: Missing manifest file.
Message: Error uninstalling package.

Status Name Location Type VersionDateAuthor Folder Package ID ID   Sendy Integration for JoomlaSitePackage1.1.02020/01/13SourceCoast | www.sourcecoast.comN/A 
Last edit: 3 weeks 3 days ago by brirem.
Support Specialist
Ahh, I hadn't seen that tool yet :)

You can ignore the warning for the JFBConnect auth, system and user plugins. Looking at the descriptions on my test J4 site for that tool, it looks like it just doesn't know where to fetch the updateserver information for those plugins. We just put the update version info in the top level JFBConnect package. When you install the JFBConnect package, all those get updated as well.

I will put an item in our to-do list to investigate fixing the warning in a later release.

-Melissa
Thanks. We just posted to this thread at the exact same time. :). Please see above about uninstalling Sendy Package error.

Thanks
Support Specialist
Yeah, we haven't updated Sendy for Joomla 4, so I'm not surprised there are hiccups.

For Sendy, there is a module, system plugin, user plugin, and a library. You can go down the route of uninstalling each of those manually (deleting the files and the entry out of the extensions table). However, one thing you might want to try is to reinstall the package first and then uninstall again and see if the error goes away. But I would not be shocked if you need to do some manual cleanup.
I'm still in 3.10.2, removing things before the upgrade to 4.  That's where I got the error on removing the sendy package.  Please see attached screenshot from PHPMyAdmin.  Is this what I delete in the table?
Attachments:
Support Specialist
Yes, that looks like the correct entry from the extensions table. I'd also check your #__update_sites table. If there's an entry in there, grab the ID first and delete the row in the #__update_sites_extensions table as well. Then delete the one from #__update_sites too.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy