• Index
  • » Users
  • » xtremedesign
  • » Posts

Posts

Posts

Can u help me with what code i should put where in order to put the Jomsocial module features (hello_me) in your JFBCOnnect Module. I like the features for example New Messages, My Photos, My Video etc. Again I preferr to use your module as has better functionality compared Jomsocials.

I am just needing to know what file to get the code from in your JFBmodule ( i am assuming it is in the modules folder pertaining (mod_jfbclogin) either the mod_jfbclogin.php or default.php and paste which code into the (mod_hellome folder) mod_hellome.php file. Again ultimate i would like to use your facebook connect functionality instead of Jomsocials Facebook Connect.  I am hoping that you will soon come up with a module that has similiar features as their.  But I understand that functionality is more important. Hope you can help. Thanks

I am using version:  2.1.2 of JFBConnect. But I just realized that the Login module I am using that has the the facebook connect feature is by Jomsocial's latest version.  I have posted this question in their forum as well and still no response.  The login module supplied by Jomsocial and also the main page for the Jomsocial community has the Connect with Facebook Icon: <!-- m --><a class="postlink" href="http://www.detroitvipclubs.com/index.php?option=com_community&view=frontpage&Itemid=69">http://www.detroitvipclubs.com/index.ph ... &Itemid=69</a><!-- m -->

Is this something that you can modify? If so, at this point I have no problem paying a fee for this modification. Please let me know if you are interested.

Using JFB Connect, I have Facebook users using their credentials and then sent to the details page to add their email address. 

Problem: the component creates a bogus email address that always ends in foo.bar.

Solution NEEDED: I would like to remove the email address created so when the user gets to this page and hits save, ultimately forcing them to enter a email address.

Problem:  adding a fake email address does not allow for me collect their email address. Adding the bogus foo.bar email when prefilled does not remind the user that i need their email. By having it blank forcers the user to enter the email address.

Example of a bogus email address entered: <!-- e --><a href="mailto:[email protected]">[email protected]</a><!-- e -->


Any wld be greatly apprecited

Found solution in another thread somewhere else:

Edit the file located at: /components/com_jfbconnect/helpers/facebookhelper.php
Edit line 122

remove: include_once(JPATH_ADMINISTRATOR.DS.'components'.DS.'com_jfbconnect'.DS.'assets'.DS.'facebook-api'.DS.'facebook.php');

replace with: include_once( JPATH_SITE.DS.'components'.DS.'com_community'.DS.'libraries'.DS.'facebook.php' );

Hope this helps

This is the error message i am receiving:

Fatal error: Cannot redeclare class facebookrestclientexception in /var/www/vhosts/detroitvipclubs.com/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/facebookapi_php5_restlib.php on line 2690

Getting the following error message: Fatal error: Cannot redeclare class facebookrestclientexception in /var/www/vhosts/detroitvipclubs.com/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/facebookapi_php5_restlib.php on line 2690

Anyone know what this means?

After installing latest version of JFB Connect component (com_jfbconnect_j1.5_v2.1.2.zip) and Facebook Invite module (mod_jfbcinvite_j1.5_v2.1.0.zip), I created an article page that will show the Facebook Invite module (user2 position). I have enabled all plugins and the module. When i go to view the page created with the module, i get a blank page: <!-- m --><a class="postlink" href="http://www.detroitvipclubs.com/index.php?option=com_content&view=article&id=69&Itemid=91">http://www.detroitvipclubs.com/index.ph ... &Itemid=91</a><!-- m -->

FYI: I have the latest version of Jomsocial : com_community_pro_1.2.192.zip. This update includes Facebook connect but i am also having issues with the Jomsocial integration. This feature is still not able to intergrate with facebook. I currently have a topic posted on this site but still no response or aid in this matter.

Any help will be greatly appreciated.  The website in question is <!-- m --><a class="postlink" href="http://www.detroitvipclubs.com">http://www.detroitvipclubs.com</a><!-- m -->.

This searches all files for the text "SERVICES_JSON_SLICE" and will help us figure out where the problem is coming from. Anywhere from 5-20 lines will be spit out starting with filenames. Please provide the filenames here.

Answer:
login as: root
[email protected]'s password:
Last login: Sun Mar 08 2009 09:07:59 -0500
No mail.
[[email protected] ~]# grep -R 'SERVICES_JSON_SLICE *
[[email protected] ~]# cd /var/www/vhosts/hypedetroit.org/httpdocs/
[[email protected] httpdocs]# grep -R 'SERVICES_JSON_SLICE *
plugins/system/pc_includes/JSON.php:if(!defined('SERVICES_JSON_SLICE')){
plugins/system/pc_includes/JSON.php:define('SERVICES_JSON_SLICE',   1);
plugins/system/pc_includes/ajax.php:            if(!defined('SERVICES_JSON_SLICE'))
plugins/system/pc_includes/ajax.php:            if(!defined('SERVICES_JSON_SLICE'))

2) Go into the Joomla administration backend, and go to "Help->System Info" and let us know what version of PHP your using. In 5.2 (I think), JSON was included natively. I'm going to guess you're using something between 5.0 and 5.2, which may be aiding in this issue.

Answer:
PHP Built on:        Linux host.xdworksserver.com 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:02 EDT 2007 i686
Database Version:     5.0.22
Database Collation:     utf8_general_ci
PHP Version:     5.1.6
Web Server:     Apache/2.2.3 (Red Hat)
Web Server to PHP interface:     apache2handler
Joomla! Version:     Joomla! 1.5.9 Production/Stable [ Vatani ] 9-January-2009 23:00 GMT
User Agent:     Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

I will try fix now

I am using a Linux server

This is the error messgage when I set error reporting to maximum and placing the Facebook Login Module on the home page in any module position:

Notice: Constant SERVICES_JSON_SLICE already defined in /var/www/vhosts/hypedetroit.org/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/jsonwrapper/JSON/JSON.php on line 64

Notice: Constant SERVICES_JSON_IN_STR already defined in /var/www/vhosts/hypedetroit.org/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/jsonwrapper/JSON/JSON.php on line 69

Notice: Constant SERVICES_JSON_IN_ARR already defined in /var/www/vhosts/hypedetroit.org/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/jsonwrapper/JSON/JSON.php on line 74

Notice: Constant SERVICES_JSON_IN_OBJ already defined in /var/www/vhosts/hypedetroit.org/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/jsonwrapper/JSON/JSON.php on line 79

Notice: Constant SERVICES_JSON_IN_CMT already defined in /var/www/vhosts/hypedetroit.org/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/jsonwrapper/JSON/JSON.php on line 84

Notice: Constant SERVICES_JSON_LOOSE_TYPE already defined in /var/www/vhosts/hypedetroit.org/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/jsonwrapper/JSON/JSON.php on line 89

Notice: Constant SERVICES_JSON_SUPPRESS_ERRORS already defined in /var/www/vhosts/hypedetroit.org/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/jsonwrapper/JSON/JSON.php on line 94

Fatal error: Cannot redeclare class services_json in /var/www/vhosts/hypedetroit.org/httpdocs/administrator/components/com_jfbconnect/assets/facebook-api/jsonwrapper/JSON/JSON.php on line 118

I currently have JomSocial installed and I am trying to install and configure. I have the facebook api complete, enabled both plugins, enabled the module, but while in configuring JFBConnect and I click on "Overview" I get a blank page.  I also noticed that when I create a menu item pointing to the component JFBConnect its stays stuck and save or apply do not appear.  Also when I enable the FAceBook Login module on any page,or module position the page goes blank as well.  I am hoping that there is a solution to this as I am very eager to use.  Here is the url it point s to when clicking on "Overview" in the configuration of JFBConnect: <!-- m --><a class="postlink" href="http://www.hypedetroit.org/administrator/index.php?option=com_jfbconnect">http://www.hypedetroit.org/administrato ... jfbconnect</a><!-- m -->

  • Index
  • » Users
  • » xtremedesign
  • » Posts

Board Info

Board Stats
 
Total Topics:
11498
Total Polls:
0
Total Posts:
48407
Posts today:
6
User Info
 
Total Users:
47473
Newest User:
martinpleon
Members Online:
0
Guests Online:
1048

Online: 
There are no members online
Social Stream
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program