• Index
  • » Users
  • » mel
  • » Posts

Posts

Posts

When I attempt to log in on FB, I get the following error in the FB login dialog:

Can't Load URL: The domain of this URL isn't included in the app's domains. To be able to load this URL, add all domains and subdomains of your app to the App Domains field in your app settings.

In your Facebook app on developers.facebook.com > Settings > Basic, make sure you have a valid value for the "App Domains" setting. You can also go into Autotune in the backend to check to see what we recommend for this setting value.

-Melissa

Mar-21-18 13:45:00
Category: JFBConnect

Great, glad I could help resolve the issue.

-Melissa

Save the channel in the backend. Then, on the front-end of your website, use the FB login button from the SCLogin module to log in with the Facebook credentials for that FB user. You should then be prompted for these permissions. *Do not use Joomla credentials on the front-end or you will not get the permission prompt.

-Melissa

Mar-20-18 13:36:29
Category: JFBConnect

Thanks. I didn't see the login module on the page originally, which is why I asked for more details.

When I attempt to use the log in button there is a failure in finding SCLogin's otpcheck.php file, which is necessary when Two Factor Authentication is enabled on your site. There is some security extension or htaccess rule that is preventing that file from being loaded. If I directly go to the file at /modules/mod_sclogin/ajax/otpcheck.php, there is a 403 Forbidden page that is loaded.

-Melissa

Mar-19-18 14:38:26
Category: JFBConnect

Could you please provide more details on how to reproduce this on your page please?

I created a regular Joomla account (not with social credentials), activated it, logged out and was able to log on properly at /index.php?option=com_users&task=login. Are you still having this problem? Is there a specific URL that the behavior occurs on?

-Melissa

First, set the cache duration to 0 in JFBConnect > Configuration area. This will force the posts to be pulled on refresh. It's possible the information Twitter was returning is incorrect and maybe that's been resolved.

I'd also like to see what URL for the image the channel post is pointing to, but there's a 404 error on the https://www.youdopet.com/investor-relations page.

-Melissa

Could you give a specific URL on which you're experiencing the problem? Do you mean the comment box is no longer rendering, comments are not being displayed when you enter them, comments not being made to your Page, etc?

If you're referring to comments being posted on both pages and your website, as I mentioned on the other thread about comments, Facebook has recently removed this Comment Mirroring functionality. It is no longer available and that is out of our control. If you're referring to other problems such as not rendering, more details are necessary where we can see and try to reproduce the behavior.

-Melissa

Mar-07-18 15:06:04
Wrong description while sharing article on Twitter
Category: JFBConnect

Could you also add permissions for:
* Access Configuration Area
* View Open Graph Debugger

-Melissa

Mar-07-18 02:47:43
Wrong description while sharing article on Twitter
Category: JFBConnect

Thanks for the updated permissions. I think that I've narrowed this down to a change that went into the latest 7.2.4 release and am working on a fix. If it passes my automated test suite, I can then make the change on your site for you to check it out.

-Melissa

Mar-06-18 15:48:50
Wrong description while sharing article on Twitter
Category: JFBConnect

I'm sorry for the delay in response. I just realized I didn't reply to your previous PM. The admin credentials that you provided for the backend do not have the proper permissions to look at the different JFBConnect configuration areas. Specifically I am trying to look at the Social Meta area.
Can you either
1) set the permissions by going into JFBConnect backend and clicking on the Options bottom in our toolbar (right next to the Autotune button). Then set the "Configure Open Graph" permission for the user group that user is in to Allowed
or
2) Upgrade that user to Super Admin.

-Melissa

Mar-06-18 15:15:29
Comment not being shared between website and Facebook.
Category: JFBConnect

Facebook comment are not showing on website

Could you describe this in more detail? If I visit one of your articles I see comments being displayed.

website comment are not appearing on Facebook Page

Comment Mirroring functionality has been recently removed by Facebook as of 2/6/2018, as described here. If you're using a different mechanism to show your website's comments on your FB page, please let me know the details on how you've set this up.

-Melissa

I see that you have a valid subscription. Please make sure that you're using the correct subscriber ID in Autotune. You can verify that you're using the right one by logging in here at sourcecoast.com > My Account menu > My Profile. The value will be on the right-hand side of the page.

If you have the correct ID, then visit this page in your backend and click on the Autotune refresh Toolbar button to refresh the subscription status:
administrator/index.php?option =com_jfbconnect&view=autotune& task=fbappRefresh

-Melissa

In the 'System - EasySocial' plugin, try disabling the "Enable com_users Redirection" setting to see if that resolves the behavior. Most of the time when this issue happens, other extensions are redirecting to a different page.

-Melissa

Mar-05-18 13:55:01
Category: JFBConnect

It sounds as if the tags aren't being set correctly if the share image preview and descriptions are not set correctly.

To do this, you'd need to
1. Enable the 'Open Graph - K2' plugin that comes with JFBConnect. When enabled, JFBConnect attempts to set the image/description/etc tags on the page from the K2 item content.
2. If you want further control of what image or text is set, you'd create an object in the JFBConnect backend > Social Meta > Objects area. (You don't need to create one in the FB dev area).
3. After you set the tags, you'd need to manually re-scrape the page to see if the new tags are set up correctly. You can scrape the page using the Facebook Sharing Debugger

If those tips don't help, please provide a specific URL where you're seeing the problem so I can the tags on the page.

-Melissa

Please view this post for instructions on how to change the order of social sharing buttons that are added by the content plugin.

-Melissa

Feb-26-18 22:03:50
Errore Errore API Facebook:(#10) Changing app settings through API calls has been disabled for...
Category: JFBConnect

I am sorry for the delay in response. This is controlled by a setting in your Facebook application. Go into your app on https://developers.facebook.com/ and navigate to Settings > Advanced. If you scroll down on that page, there's an option called "Allow API Access to App Settings" that needs to be enabled to resolve this error. Once it's on, you'll be able to use Autotune in JFBConnect to set up the application.

-Melissa

Feb-18-18 13:46:07
Category: JFBConnect

We've received contact us submissions since your post. Please feel free to try again or send us a private message if you don't want your issue posted on the forums. (Use the envelope icon under our avatar in this thread to send the PM).

-Melissa

Feb-17-18 22:18:00
Topic: Error
Error
Category: JFBConnect

Thanks for finding our typo. It's all fixed now.

-Melissa

Feb-16-18 16:00:34
I just noticed the LinkedIn Social share counts have disappeared. Could you let me know how to...
Category: JFBConnect

Yes, it looks like they've followed suit to other social networks and removed the share count permanently. There's a new notice now on the LinkedIn developer page that was not there previously. It brings you to this new blog post regarding the count.

-Melissa

No worries. Glad you were able to find the issue and resolve it current/smile

-Melissa

To add specific Open Graph tags via JFBConnect, you would use the following format

{SCOpenGraph og:type=video.other}
{SCOpenGraph og:url=FULL/PATH/TO/VIDEO/URL}
{SCOpenGraph og:title=Sample Video Title}
{SCOpenGraph og:image=https://s-static.ak.fbcdn.net/images/devsite/attachment_blank.png}

* Ignore app_id. JFBConnect sets this automatically

After setting the Open Graph tags for the page to use type of video.other, the click of the JFBCShare button should share the video. Facebook wants you to share a page and they will generate the appropriate video preview, etc. To add the button, it should just be in with 1) another easytag {JFBCShare} or {JFBCShare href=FULL/PATH} or 2)the SCSocialWidget module

If you scroll to the bottom of the FB video tags documentation, there are additional tags you can set for the size of the video and other options.

Also, as you update the Open Graph tags on the page, please use the Facebook Sharing Debugger to re-scrape your pages to get the changes to take effect.

-Melissa

This functionality was removed by Facebook on February 5th, 2018. It's not clear on the Facebook social plugins page or the Graph API changelog that it was removed, but I found it on a blog post: https://developers.facebook.com/blog/po … offerings/

I will be removing the widget for the next version of JFBConnect.

-Melissa

Feb-14-18 15:55:31
Cannot see image while sharing Joomla article via Twitter
Category: JFBConnect

1. Can you try creating the object? This would help to address the description as well.

2. Enable the Social Toolbar setting in the JFBConnect > Configuration > General area. Then log in as an admin on the front-end and click the Social Meta button. Let me know what any row values for twitter:description or og:description that show up in that list.

3. If those don't help, you can send me a PM with superadmin credentials. I might need to poke around in your backend to check out your settings/plugins.

-Melissa

All social networks use the exact URL to track share/like counts. This includes the http/https scheme. When your URLs changed from http:// to https://, that changed the URL, which is why your counts reset to 0. The old counts are still intact on the http:// URLs. What you can do is set the "Force Scheme" setting in the JFBConnect -> Configuration area to "http://". That will make all sharing features use the http:// URL. Your site should still redirect the user to https:// though and you'll keep the original sharing counts from before the switch.

-Melissa

What version of JFBConnect are you using? I did make some bug fixes in the latest release regarding Open Graph tags. If you have not upgraded yet, I would suggest that you try this first. If you have, well, then that's a problem that I probably introduced...

* If you log in as an admin on the front-end and have the Social Toolbar enabled (from the setting in the JFBConnect backend > Configuration > General area), can you pull up the "Social Meta" panel. This will tell us what tags JFBConnect is trying to set and if any are ignored.
* Could you let me know the specific SCOpenGraph easy-tag that you're using and I will try to add it to my test site to reproduce the issue?

-Melissa

  • Index
  • » Users
  • » mel
  • » Posts

Board Info

Board Stats
 
Total Topics:
11497
Total Polls:
0
Total Posts:
48402
Posts today:
7
User Info
 
Total Users:
47468
Newest User:
hannatee
Members Online:
2
Guests Online:
958

Social Stream
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program