• Index
  • » Users
  • » mel
  • » Posts

Posts

Posts

Glad we could help. Let us know if you run into any further issues.

-Melissa

Aug-19-18 13:13:53
I would like all social media icons to fit into one line.
Category: JFBConnect

There are two places you can do this.

* Set the SCLogin module > Social Button Settings > "Image Style" setting for each of the social network providers. If you'd like to just change the SCLogin module button sizes, you can do it here.
* If you'd like to change it for any time the login buttons are displayed (e.g. the Joomla login page, with easy-tags, etc), also set the JFBConnect backend > Configuration > "Default Login Button" setting for each provider tab.

-Melissa

The Open Graph tag on both of those pages is incorrect and pointing to the homepage instead of the current page:

Code:

<meta property="og:url" content="http://www.mazalien.nl"/>

So even though there's an image tag and description tag on the page with the share button, when FB scrapes the page, it looks at what the og:url is pointing at to grab an image and description to display. Have you set any defaults in the backend Social Meta > Configuration area for URL? If so, please remove the og:url setting. JFBConnect determines the value based on the current page.

Remember, once you make any changes to the OG tags, you'll need to manually re-scrape here on FB to get the new values.

-Melissa

Aug-19-18 12:56:17
Error with jfb connect
Category: JFBConnect

There are only two providers that use that code: Twitter and Yahoo.

If you're encountering that error with Twitter, then please follow these simple steps to update your Twitter application:

To fix, please:
* Go to the Twitter Apps Area
* Click into your app
* Go to the 'Settings' Tab
* In the 'Callback URLs' section, add all variations of your domain with 'index.php' at the end. So, for this site, we would add:

Code:

http://sourcecoast.com/index.php 

http://www.sourcecoast.com/index.php
https://sourcecoast.com/index.php
https://www.sourcecoast.com/index.php

Twitter changed something on their side about 2 months ago that requires this change, so you would have been seeing it since then.

-Melissa

Aug-15-18 14:19:15
Category: JFBConnect

To test the functionality of login or the channel posting without going through the App Review process, you will need to set your Facebook App to development mode. You should then be able to proceed to test that it's working. However, once you set the app live, you must go through the App Review process. There's no way around this.

Please note that once you go live and are waiting for App Review to complete, you should be able to continue to use the posting/profiles features without having to re-grant the permissions.

When you're ready to go through the App Review process, take a look at the JFBConnect backend > Scope Review section. We list out the scopes that you've configured within JFBConnect. These will be the ones you need to get approved in the review.

-Melissa

Yep! I've checked in the change for the next release. I'll just have to run it through my automated test suite to make sure nothing breaks.

-Melissa

If I use Facebook's Like Button configurator at https://developers.facebook.com/docs/pl … nfigurator and put in your URL, there is no like button rendered there either. Looking at your source, the FB javascript is initialized properly and we're passing everything in correctly to FB, but what comes back is not rendering. I think you need to submit a bug report to Facebook.

-Melissa

There are two calls to the accounts endpoint:

1. In /components/com_jfbconnect/libraries/provider/facebook/channels/fields/facebookpagelist.php at line 28. Change

Code:

$pages = JFBCFactory::provider('facebook')->api('/' . $uid . '/accounts/', $params, true, 'GET');

to

Code:

$pages = JFBCFactory::provider('facebook')->api('/' . $uid . '/accounts?limit=100', $params, true, 'GET');

2. In /components/com_jfbconnect/libraries/provider/facebook/channel/page.php at line 32. Change

Code:

$accounts = $this->provider->api($uid . '/accounts', $params, true, 'GET');

to

Code:

$accounts = $this->provider->api($uid . '/accounts?limit=100', $params, true, 'GET');

Let us know if this works to resolve your problem. I will add a ticket to our tracker to check this in for the next release.

-Melissa

Could you let me know a link to the FB bug report? I'd like to subscribe in case there's anything we need to be doing differently/better.

-Melissa

I'm not aware of a limit to the amount of pages/groups/etc returned from Facebook. There's nothing in our code to limit what we display. Could you try to use the FB Graph API Explorer with the following request:

Code:

/me/accounts

Are all of the Pages visible when you Submit? This is the API call we use in JFBConnect. It will return the list of pages that you are an admin for. If there's a discrepancy (e.g. all the pages show in FB but not JFBConnect), that will shed some light on the problem.

-Melissa

I'm glad it was easy to resolve.

In our doc page for OG objects, after that screenshot of the Object Types, we call out that the plugins need to be enabled.

The list of available object types is created from the enabled Open Graph plugins on your site. If you cannot find an expected object type despite having a supported third party extension on your site, please ensure that 1) JFBConnect has properly installed the Open Graph plugin on your site and 2) that the plugin is enabled. .....

I'll update it to be more prominent though. Thanks for the suggestion.

-Melissa

Aug-10-18 01:18:39
Force SCLogin to a https page?

When I look at the page using F12 in Firefox I get a warning on the console tab saying : Password fields present on an insecure (http://) page. This is a security risk that allows user login credentials to be stolen.

Are you looking at the https version of the page in Firefox? Can you verify in the source that the setting is working and the form is directed to submit to https? Could you send a specific URL where we can see the behavior in action?

-Melissa

If you are trying to create an object for K2, then you'll need to enable the plugin in the Joomla backend > Extensions > Manage > Manage area. From the above "No Open Graph plugins are enabled" message it looks like the plugin is disabled. Search for 'Open Graph - K2' and enable that plugin. It should be as simple as that.

Also, from that list of installed plugins, it looks like the only Open Graph plugin installed with JFBConnect was our 'Open Graph - K2' plugin.  If you're missing an Open Graph plugin but have the third party extension installed, it's likely that JFBConnect was installed first, before the other extension. On installation, JFBConnect detects which third party extensions are installed and only installs our corresponding plugins. To get the plugin, you should just be able to reinstall JFBConnect.

Hope this helps explain but let us know if you need further help.

-Melissa

Jul-31-18 13:26:14
changes in the view after identifying

This is usually just CSS styles that you'll need to add. If you provide a specific URL, I could take a look to see if I have a suggestion on what to change.

Once you have a new style, we'd recommend putting them into your own theme files, so you don't lose any changes on updates. To read more about creating a theme, please read here.

-Melissa

Jul-30-18 14:31:34
Posting by access level configurable?
Category: JFBConnect

Yes, an option would be a good idea... but no, we don't have that setting. I've added it as an enhancement request to our issue tracker.

In the meantime, the code can be found in the Open Graph plugin for Joomla content - /plugins/opengraph/content/content.php at line 390. The existing code checks if the access variable is 3 for special or 6 for super user

Code:

if(!$this->isArticleSpecial($article->access)) //Do not auto-post special/Super User items

Since you want to only post for Public access, you can do the following instead.

Code:

if($article->access == '1')

-Melissa

Glad it was an easy fix current/smile

Twitter has changed their application requirements recently. You'll need to go into your Twitter app and update the "Callback URL" to include index.php.

To fix, please:
* Go to the Twitter Apps Area
* Click into your app
* Go to the 'Settings' Tab
* In the 'Callback URLs' section, add all variations of your domain with 'index.php' at the end. So, for this site, we would add:

Code:

http://www.sourcecoast.com/index.php

https://www.sourcecoast.com/index.php
http://sourcecoast.com/index.php
https://sourcecoast.com/index.php

Let us know if you continue to have issues after updating this setting.

-Melissa

The buttons in the modal and on the main page both have the same classes .btn and .btn-primary. If you put the !important tag on the hover and focus styles you made, the changes should work for both sets of buttons for the hover and focus behavior. For instance:

Code:

 .sourcecoast .btn:hover, .sourcecoast .btn:focus {

background-color: #9DCB80 !important;
}

and

Code:

.sourcecoast .btn-primary:hover, .sourcecoast .btn-primary:focus {

background-color: #9b3c99 !important;
}

-Melissa

Jul-03-18 14:38:31
Facebook Comments Display Error
Category: JFBConnect

Glad I could help and it was an easy fix.

Saw there was no response to this latest message, so I wanted to point out that we're working on an improvement for this and it should be included in our next release.

-Melissa

Jul-03-18 14:20:08
Social Login not working properly
Category: JFBConnect

For Facebook:
That error looks like the redirect URIs are set incorrectly in your application. Please follow the instructions in our FB application setup guide. Specifically, pay attention to Step 21 for "Valid OAuth redirect URIs"

For Twitter:
That error has started cropping up recently as Twitter made a change to their app settings in mid June. Please double-check your Twitter's app setting for "Callback URL". The URL should be your website followed by index.php, like:

Code:

https://yoursite.com/index.php

The Twitter setup guide was updated to include the index.php portion recently, which you may have missed.

-Melissa

Jul-03-18 14:10:49
Facebook Comments Display Error
Category: JFBConnect

There are two options to fix this:

1. Inspecting the widget on your page, the .fb_iframe_widget class is getting a left of 7%. That is coming from what looks like a custom module or style block on your page. If you shift this to 0, the entire comments box will fit.

2. There is also a width parameter when the Comments widget is selected. You can enter a pixel amount and, I believe, 100% if you want to fill the content area. Just take into account the 7% left in whatever value you put.

Hope this helps current/smile
-Melissa

Jul-02-18 19:10:57
I use one of the modules (Facebook Page Display) to show the events. I would like to remove the...
Category: JFBConnect

We're not adding that link. Facebook Page Display (mod_facebook_page_display ) is not a module that comes with the JFBConnect package. If you're going to continue to use JFBConnect, we recommend against using multiple FB extensions (e.g. JFBC and that module are both inserting the FB sdk.js and can lead to unexpected behavior). I'd suggest that you instead use our SCSocialWidget. Select Provider Facebook and Page Plugin as the widget type to get the same widget you're currently displaying.

-Melissa

Jul-02-18 13:04:32
Https connection required ?
Category: JFBConnect

Facebook now requires HTTPS for Facebook Login for all new applications (since March 2018). If you're using an older FB app, you can disable the "Enforce HTTPS" setting to try to get it going. However, all apps will have HTTPS required by October 6, 2018.

You can read more about FB's requirements on their blog post here

-Melissa

Jul-02-18 11:57:40
Topic: update
I just install the update and my whole page disapprear frontend and backend. Pls help!
Category: JFBConnect

You'll need to disable the JFBCSystem plugin. That should get your site back up and running, and then we can narrow down the actual issue.

If you have access to the admin area, please go to the Plugin Manager and disable the JFBCSystem plugin directly.

If you can't access the admin area, please edit the /plugins/system/jfbcsystem/jfbcsystem.php file. Around line 26, you'll see:

Code:

    function __construct(& $subject, $config)

    {

Add 'return;' after that line, so it looks like:

Code:

    function __construct(& $subject, $config)

    {
         return;
         ...don't touch anything else...

Once you can get back in your admin area, I'd recommend disabling the Open Graph - EasyBlog plugin as it sounds like that's where the error is coming from.

Then, you can remove the 'return;' line from the JFBCSystem plugin and JFBConnect should work like normal.

Hopefully that gets you going, but the EasyBlog integration with JFBConnect will be disabled. If you need that functioning, please let us know what the full error message is that you were getting so we can investigate. If you're no longer using EasyBlog, then you should be good to go.

I hope that helps,
Melissa

  • Index
  • » Users
  • » mel
  • » Posts

Board Info

Board Stats
 
Total Topics:
11618
Total Polls:
0
Total Posts:
48821
Posts today:
4
User Info
 
Total Users:
47671
Newest User:
essentee
Members Online:
2
Guests Online:
1169

Social Stream
SourceCoast Joomla Social Extensions
Friday, 25 May 2018
JFBConnect 8.0 Coming Soon! Stay tuned.
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program