• Index
  • » Users
  • » cyclemycity
  • » Posts

Posts

Posts

Alex,

I'm getting the following error 'Fatal error: Class 'Sendy' not found' when registering a new user through the app I'm developing. It works fine if I register the user on the website, but not through the app, so I'm wondering what files I might need to include in the app's api so that Class Sendy is defined? It looks like it is defined in libraries/sendy.php, but I'm not sure how to get it working from outside Joomla. Can you give me any pointers? Currently I have had to disable the user plugin to get the app registration to work.

Thanks,
Matthew

May-25-14 06:02:14
Forum: Sendy

Hi Alex,
In addition to the name field, while you are at it, it would be good to just allow the administrator to select the fields assigned to the list (including custom fields) - I use first and last name so I can greet people by their first name...

Looking forward to the next instalment!

Cheers,
Matthew

Sorry for the delay in getting back to you.

I uninstalled all the JLinked items. I think they were already uninstalled because I got lots of warnings such as:
JFolder: :files: Path is not a folder. Path: /var/www/html/plugins/user/jlinkeduser
JFolder: :files: Path is not a folder. Path: /var/www/html/plugins/user/jlinkeduser
JInstaller: :Install: Cannot find XML setup file

and they do not appear in my directory structure. I got one error, trying to remove the component (Error uninstalling component.) and the Jlinked component is still in the manage tab of the extension manager, but there is no folder in /components and it is not in the admin component menu, so I don't think it is there any more...

Anyway, the error is not happening (although I'm not sure if it was related to removing this stuff or not, I suspect not, as I've updated a few things recently and not noticed the error coming back...

Thanks,
Matthew

Hi,

Recently I've been getting this warning when logging in "JAuthentication: :authenticate: Failed to load plugin: plgauthenticationjlinkedauthentication"

I've upgraded to jfbconnect and I thought jlinked was removed (but it is still in the component menu in the admin panel too, although clicking it gives an error).

Do you know what may cause this?

Thanks,
Matthew

Alex,

Thanks for getting back to me.

I was able to solve the problem after you mentioned that it could have some graphical problems. I found the element names using another template and was able to trace the problems. I made the following changes to sc_bootstrap.css. I'd appreciate it if you could let me know if I should be changing different elements to avoid somethig I haven't found/noticed from getting mixed up as a result!

1. I added "display: block !important; " to ".sourcecoast.modal.fade.in" around line 95 as it was being overruled by "display: none !important" in a BS3 .hide
2. I added "bottom: inherit;"  to ".sourcecoast.modal.fade.in" around line 95 as it was being overruled by a "bottom: 0" which stretched the modal to the bottom of the screen.
3. I commented out   /*margin: 0 0 0 -40%;*/ in .sourcecoast.modal as it pushed the modal off-center.
4. I added "display: inline-block;" to ".sourcecoast button, .sourcecoast input" around line 240 as the check box and 'remember me' didn't lie up. This is the one that I'm most concerned may have adverse effects elsewhere, but I'm not sure - I haven't seen anything.

Thanks,
Matthew

By the way, I'm trying to use it on T3 BS3 Blank... Thanks.

Does SCLogin work with BS3? I'm trying a new template on my local host and can't get the modal box to appear when clicking login.

Thanks,
Matthew

Apr-06-14 05:49:04
I can only see the default content for the share popup, but need to customise it.
Category: JFBConnect

Alex,

I wonder if that is related... Although the Social Media Tags and Create Post buttons are displayed on my page they don't do anything. Is there some setting that may be wrong that would allow them to be displayed on the page but not function?

Matthew

Apr-03-14 22:03:36
I can only see the default content for the share popup, but need to customise it.
Category: JFBConnect

Thanks for the suggestions (the image is now attached from the last post). I ran the debug and got the following error:
Object at URL 'http://cyclemycity.com/index.php?option=com_community&view=events&task=viewevent&eventid=75&groupid=&Itemid=25' of type 'article' is invalid because the given value '/index.php?option=com_community&view=events&task=display&Itemid=25' for property 'og:see_also' could not be parsed as type 'url'.

I 'fixed' the error by adding http://cyclemycity.com/ to the start of all the og:see_also tags in com_community/helpers/head.php, but I'm not sure that I should be changing this as I would have thought that you'd have noticed if this was wrong. Should this file be changed, or is there a wrong setting somewhere that should be adding this to the start automatically?

I then got the following for the title:
og:title    Future weekend ride's Event

So, then I also deleted the " 's Event " from en-GB.com_community. Again, I don't really want to do this because it is probably used in other circumstances. However, I then got the og:title Future weekend ride, which is what I wanted to see, but should be getting it via the SCOpenGraph custom parameter instead of modifying the language file...

The SCOpenGraph custom parameters are putting the title and image tag into the source code, but the Facebook Share popup is not picking them up. Maybe it is not adding them to the header as they appear at the very bottom of the code (twice), in relation to the 'Social Metatags | Create Post | X' buttons (there are 2 sets, but neither seem to do anything on my page). The only place it appears near the top is a few lines after the og:see_also tags, and I'm surprised are not being picked up by the Facebook Debug or Share popup. That set of tags looks like:

<meta name="twitter:title" content="Future weekend ride"/>
<meta property="og:title" content="Future weekend ride"/>
<meta name="twitter:image" content="http://www.cyclemycity.com/images/stories/flash/slider2.jpg"/>
<meta property="og:image" content="http://www.cyclemycity.com/images/stories/flash/slider2.jpg"/>
<meta property="og:url" content="http://cyclemycity.com/index.php?option=com_community&view=events&task=viewevent&eventid=75&groupid=13&Itemid=25"/>
<meta name="twitter:description" content="A ride in the hills?"/>
<meta property="og:description" content="A ride in the hills?"/>
<meta name="twitter:card" content="summary"/>
<meta property="og:type" content="article"/>
<meta property="fb:app_id" content="..."/>
<meta property="og:locale" content="en_gb"/>
<meta property="og:site_name" content="Cycle My City"/>

Looking at the Graph API Scraped URL at the bottom of debug I see that the custom parameters are not being scraped.
The below is from the Graph API:

{
   "id": "...",
   "url": "http://cyclemycity.com/index.php?option=com_community&view=events&task=viewevent&eventid=75",
   "type": "article",
   "title": "Future weekend ride",
   "locale": {
      "locale": "en_gb"
   },
   "image": [
      {
         "url": "http://cyclemycity.com/components/com_community/assets/event.png",
         "width": 160,
         "height": 160
      },
      {
         "url": "http://cyclemycity.com/components/com_community/templates/default/images/cover/event-default.png"
      }
   ],
   "description": "A ride in the hills?",
   "see_also": [
      "http://cyclemycity.com/index.php?option=com_community&view=frontpage&Itemid=22",
      "http://cyclemycity.com/index.php?option=com_community&view=groups&task=display&Itemid=19",
      "http://cyclemycity.com/index.php?option=com_community&view=photos&task=display&Itemid=22",
      "http://cyclemycity.com/index.php?option=com_community&view=videos&task=display&Itemid=22",
      "http://cyclemycity.com/index.php?option=com_community&view=events&task=display&Itemid=25"
   ],
   "site_name": "Cycle My City",
   "updated_time": "2014-04-04T03:00:33+0000",
   "created_time": "2014-04-03T03:27:46+0000",
   "application": {
      "id": "...",
      "name": "CycleMyCity",
      "url": "https://www.facebook.com/apps/application.php?id=..."
   },
   "is_scraped": true
}

I can't work out why the custom parameters (image and title - although I hacked the title to be correct, as mentioned above) are being ignored...

Do you know why the custom tags may be ignored by the scraper even though they are in the source code?

https://www.sourcecoast.com/images/agorapro/attachments/19852/mini_share-popup.png

Apr-03-14 07:15:05
I can only see the default content for the share popup, but need to customise it.
Category: JFBConnect

I have pasted the following:

                                {SCOpenGraph title=<?php echo $event->title; ?>}
                                {SCOpenGraph image=http://www.cyclemycity.com/images/stories/flash/slider2.jpg}
                                {JFBCLike href=http://www.cyclemycity.com/index.php?option=com_community&view=events&task=viewevent&eventid=<?php echo $event->id; ?> share=true}

into /com_community/templates/default/events.viewevent.php

I get the like/share buttons appearing, and the content of the share box is as per the attached (which is probably based on JFBConnect defaults, I suppose), taking the correct URL from the JFBCLike href, but the SCOpenGraph tags don't override anything...

How can I get this to work? Basically I want to get rid of the " 's Event " from the end of the title (as it does not make sense to put it on the end of an event Title, but would be fine if it was on the end of a username), and customise the image (the image shown is from the page but I want to show a static map of the event route instead).

Thanks,
Matthew

Hi,

If the user's login details (username/password) are incorrect, how do I customise the page that the user is redirected to? Users are currently being redirected to ...index.php?option=com_users&view=login, but it is blank because the user has not successfully logged in. They should just stay on the same page (...index.php) or, ideally, receive a message indicating that their login details are wrong and leave the login pop-up there to try again...
The site is www.cyclemycity.com (you'll need an Australian proxy to see it).
Thanks,
Matthew

Feb-18-14 21:45:45
I can get the login working, but can't get the same style 'logged in/log out'...

Alex,

Thanks for getting back to me. Sorry about the access, you'd need an Australian proxy to access it at the moment (until I roll out the Joomla 3 version shortly).

I've sorted it out. After a few hours of fiddling, I had a different position set on the inner template pages to the front page, so it only showed up on the front!

Thanks again.

Matthew

Feb-17-14 19:13:05
I can get the login working, but can't get the same style 'logged in/log out'...

Hi,
I have the green login boxes working fine at cyclemycity.com/j32, but after a user logs in I'm just getting some 'default' grey log out button (maybe from JomSocial?). There is only one page that I can see the green SC 'Hi Username' dropdown button that reveals the logout button. Also, the Logout View Setting tab doesn't seem to change anything on my site, so I can't work out how to get it working on all pages. I've set 'Menu Assignment' to all pages. I'm not sure what else I can tell you as I just can't work out why it isn't working properly...

Also, can you set the logout redirect to a URL, or does it need to be a menu item?

Matthew

  • Index
  • » Users
  • » cyclemycity
  • » Posts

Board Info

Board Stats
 
Total Topics:
11685
Total Polls:
0
Total Posts:
49056
Posts today:
3
User Info
 
Total Users:
47818
Newest User:
normastainfo
Members Online:
1
Guests Online:
609

Online: 
joejvgsourcecoast
Social Stream
SourceCoast Joomla Social Extensions
Friday, 25 May 2018
JFBConnect 8.0 Coming Soon! Stay tuned.
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program