Popup Module not working properly

Popup Module not working properly

Hi,

Module is not working at all on home page and it works in inner pages but not properly at all... can you please suggest why this happen... and how to solve this...

I have attached the snap shot as well so that you got to know what is going on in the inner page and on main page its not working at all...

Site url is http://www.rockmyclothes.com/  you can find the module at the bottom of the page...

https://www.sourcecoast.com/images/agorapro/attachments/16505/mini_inner-page-look.jpg

Thanks

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

I have the same issue. It pops up but I have a very dark screen.

If you want help with your computer please check: http://www.vivacomputers.nl. Also for help on distance!
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

On both of your sites, the SCLogin modal view isn't enabled, so I can't really provide much help right now. Could you enable the module in Modal view (on some interior page so it's not necessarily seen by many users) and then we can investigate what's causing the problem. Usually, it's a z-index issue in your template, but we'd need to see to understand more and provide a fix.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24140 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

Hi,

Please check it now... and also please check why the Facebook Connect is giving the error...

Thanks

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

You can try it at; http://www.vivacomputers.nl/vivacomputerstemp/

If you want help with your computer please check: http://www.vivacomputers.nl. Also for help on distance!
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

Vivacomputers,
The following line in your CSS is the problem:
/plugins/system/jat3/jat3/base-themes/default/css/template.css , line 1002:

Code:

#ja-container {

position: relative;
z-index: 5;
}

If you remove that z-index: 5; it works. That's putting your main content 'under' the grey mask that pops up. It doesn't look like removing that z-index causes any other problems, but you'll have to test on 'real' content pages of your site.

Rockmyclothes,
There's a few issues going on on your site. First, there's lots of warnings/errors that your SSL certificate isn't valid. I don't know if that's causing problems with authentication right now, but it may be. Please either install a valid SSL certificate or remove the automatic redirection to https.

Modal under grey area
This style in your template is causing a similar issue to viva above:

Code:

#gkPageContent {

-webkit-box-sizing: border-box;
-moz-box-sizing: border-box;
box-sizing: border-box;
padding: 0 50px;
position: relative;
z-index: 100;
}

I don't know what file that's in because your CSS is combined and compressed. Hopefully that helps you narrow things down though.

Not displaying on home page
My guess is that you are not displaying any component output on your home page-- you have it disabled some how. Our current Modal popup requires the component area to be displayed on a page. We append the modal popup to the component area for display. If the component is not shown, the modal will not work.

Facebook not working
What error are you getting? I just tried to login and was properly brought to the "Login / Register" page to create my account.

All,
Styles
Not asked, but when the popup does work, the styles for the inputs don't look right. We're releasing a new SCLogin module (the 3.0 stable version) either today or tomorrow. That will hopefully fix some of the styles, but there may always be some template conflicts to work through. We'll help how we can.

I hope that helps explain, but if you have other questions, let me know.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24140 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

Yep now it works. You make it very easy hehehehe. Thank you!

If you want help with your computer please check: http://www.vivacomputers.nl. Also for help on distance!
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

Hi,

Thanks for your information... I disabled the Force SSL from the admin panel... but still the Facebook login is not working... Same credentials when I use in Jomsocial its working but the Facebook is having issue... I read that Facebook API has to be defined only once... so I keep that setting only in the JFB and removed setting from all the places...

I corrected the popup functionality and its working fine but still its not displaying on Home page... and its OK on rest of the pages...

Thanks and waiting for your reply....current/smile

.

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

Hi Alex,

I am going to jump aboard this thread as I have the similar issue of Home page modal not functioning. However, you are correct if I enable front-end component output the login modal works, but when I disable it (a function of the template) it halts the login from working. Is there a workaround for this? I have disabled the front-end output for good reason.

Secondly, just a thought, is there a way to make the register function 'pop' out modal like the login does?

thanks for a great component.
(don know if I am sailing off the end of the earth here with this idea, ....but referring to our discussion about group add ins - maybe this is the component to call profiles/groups?) Ill mention it in the thread current/smile - edit: stupid me - its a login module and not a register module - forget this last statement !!!!

Edited by: petwal - May-30-13 05:10:25
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

Hi,

somehow we manage to show the module on home page but the Facebook login is still not working... can you please suggest on this.. what to do... with same API and secret key its working for Jomsocial but I don't know why its not working for JFB...

and also if we login by UID and PWD its not redirected to the specified location...

Please support us on this...

thanks

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

Further to my post earlier - I have managed to sort the front end component out by getting the developers of an event system to modify their component. So all sorted on that front. thanks

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Popup Module not working properly

vivacomputers,
Glad we could help! 1 less issue in this topic is great current/smile

Rockmyclothes,
Glad you got the module to work on the home page, it's looking good!

Facebook not working
Your site is currently loading the Facebook Javascript library 3 different times. It should only be loaded an initialized once. From what I can tell, here are the places you may need to disable it:
* Your Gavick Template. There is usually a "Enable Social" option, or something similar. Disable that.
* You cookie browser thing. Right above one of the inclusions is a div with the name "class="cc-onconsent-social". Not sure what this is, but that's my guess.
* sh404SEF? I'm not sure if this is on your site, but they can include the Facebook library as well.

Once only JFBConnect is loading and initializing the Facebook library, things should go better.

Peter,
Awesome you got things going. The requirement of showing the component is something that's planned to be temporary. We'll be moving to a different system in a future release, but for now, it's required.

A modal/popup registration form is coming. We had to start somewhere, and the login popup was that starting point. Registration will be neat as well, we know that, but it won't be tomorrow that it's available.

For registration, when we do that, we'll likely be having the ability to call our Social Profile plugins so that fields from other extensions (or whatever) can be added to the registration form. That will take a lot of work to make sure it looks good, but that's a goal.

All,
We just released the stable v3.0.0 of the SCLogin module last night. There's been some bug-fixes and new features. The biggest new feature is an option to show a menu when the user is logged in. Great for user-specific items "My Profile", etc, like we have in the top right of this page. Hopefully, you won't run into any issues with the new version, but if you do, we'll be here to help.

Finally, if you haven't already, please consider leaving a rating and review for the SCLogin module. It's a new product for us, and something we want to keep growing. The more visibility it gets, the better it is for us (and hopefully you too).
http://extensions.joomla.org/extensions … tion/24054

Thanks, and, if you're still having issues, we'll get you going!
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24140 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11684
Total Polls:
0
Total Posts:
49047
Posts today:
3
User Info
 
Total Users:
47816
Newest User:
[email protected]
Members Online:
2
Guests Online:
1144

Online: 
nbjed, skyfranky
Social Stream
SourceCoast Joomla Social Extensions
Friday, 25 May 2018
JFBConnect 8.0 Coming Soon! Stay tuned.
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program