Forum is closed

Getting a 403 error when logging in

Getting a 403 error when logging in

I get a 403 error when logging in (first time) from the mod_sclogin module.

Pls help.

Regards,
Chris

chris2005
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Could you pls help me out here? When do you expect to give me support?

Regards,
Chris

chris2005
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Hi Chris,

You may want to go to the technical team as I am not a developer but I needed to liaise with my hosting company and the JLinked team to get this resolved. There are some hints and tips in the documentation such as only having live the login initially and getting this to work first and then the rest will follow.

My issue lay with security settings and the SSL side of things. Once this was released we had to go through a series of things that are too lengthy to put on here and also would give insight into y site security so I am not able to do so. The contact I had in JLinked was Alex and he was extremely helpful.

I am presuming that you have carefully followed the set up steps on the LinkedIn API side of things as any missed settings can kick out the API working. Worth revisiting these before you jump ahead to Alex but equally if you are unsure the support level from JLinked and their technical team is superb.

Hope it all goes well,

Simon

simpre
Simon
useravatar
Offline
16 Posts
Active Subscriptions:

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Thanx for your reply.

I notice that there is data being synced to my site despite the 403 error. So I guess settings are ok.

Regards,
Chris

chris2005
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Hi Chris,

I rely quite heavily on the technical team as I am not a developer.

The team at JLinked will provide support and sorry I am not able to help further.

Kind regards,

Simon

simpre
Simon
useravatar
Offline
16 Posts
Active Subscriptions:

Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Chris,
Very sorry for the delay.

When you get the 403 error, are there any messages you're seeing or anything you can post that may help us diagnose the problem?

Beyond that, please try the following:
* Disable all JLinked Profile plugins and test again
* If that works, re-enable one plugin at a time for only the extensions you use (don't enable the JomSocial profile plugin if you don't have JomSocial enabled). Try logging in after each one you enable and see if it works. If not, let us know which plugin stops it from working.

Let us know and we'll get you going.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
23659 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Check the attachement for a screenshot of the 403 message page I get. I get this right after giving the joomla account and pw to create a new joomla account.

I have only installed the jomsocial plugin. I disabled that one but the error remains.

I have PMed you access info to the site. Maybe you can verify ...

Regards,
Chrishttp://www.sourcecoast.com/components/com_agora/img/members/12818/screenshot-403-error.png

chris2005
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Chris,
I can't see the SCLogin module anywhere on the front-end of your site. Can you PM me a link to a page where we can see it or specific instructions on how we should enable it? We don't like making modifications to sites, so would like your input on how you have things configured already.

As for the error page you show, one thing you can try is to go to the Joomla Global Configuration and set Error Reporting to "None" and turn off Gzip compression. Also, disable any 'optimizer' plugins you may have enabled. Then, that page may show a real error message that will help diagnose the issue.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
23659 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Solved. sh404sef caused the problem. Just disabled sh404sef for jlinked.

chris2005
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Chris,
Ahh, glad you got that going. Not sure why that would be necessary, but there is a lot of communication back and forth between your site and LinkedIn. If sh404SEF alters those links in a bad way, it could definitely cause a problem.

For JLinked operation, we really don't have any front-end URLs except for the registration page, which shouldn't really need to be SEF'd anyways, so you shouldn't have any drawbacks from disabling sh404SEF for JLinked.

If you run into any other issues or need anything else, just let us know!

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
23659 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Getting a 403 error when logging in

Thanx!

chris2005
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11405
Total Polls:
0
Total Posts:
48071
Posts this week:
24
User Info
 
Total Users:
47238
Newest User:
suwapoj
Members Online:
0
Guests Online:
717

Online: 
There are no members online
Social Stream
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program