Black Friday / Cyber Monday Special - 10% Off - Use "CYBER10" at checkout!

Topic-icon 500 Errors Post V6 Upgrade

Active Subscriptions:

None
7 years 9 months ago - 7 years 9 months ago #41498 by warchop
New update...just extended subscription for 6 additional months...receiving the below errors after logging in and out...my site is www.vombudsman.com. When I refresh, I'm logged in, but I cannot expect my users to do refresh after logging in. Please advise.

Warning: Cannot modify header information - headers already sent by (output started at /home/warcho1/public_html/components/com_jlinked/libraries/jlinkeddata.php:422) in /home/warcho1/public_html/plugins/system/logout/logout.php on line 63

Warning: Cannot modify header information - headers already sent by (output started at /home/warcho1/public_html/components/com_jlinked/libraries/jlinkeddata.php:422) in /home/warcho1/public_html/plugins/user/jfbconnectuser/jfbconnectuser.php on line 48

Warning: Cannot modify header information - headers already sent by (output started at /home/warcho1/public_html/components/com_jlinked/libraries/jlinkeddata.php:422) in /home/warcho1/public_html/plugins/user/jfbconnectuser/jfbconnectuser.php on line 49

Warning: Cannot modify header information - headers already sent by (output started at /home/warcho1/public_html/components/com_jlinked/libraries/jlinkeddata.php:422) in /home/warcho1/public_html/components/com_community/libraries/core.php on line 514

Warning: Cannot modify header information - headers already sent by (output started at /home/warcho1/public_html/components/com_jlinked/libraries/jlinkeddata.php:422) in /home/warcho1/public_html/libraries/joomla/application/application.php on line 810

After refreshing after logging out...I get a 404 error (I have no SEF modules installed)


Strict Standards: Declaration of JlinkedData::bindData() should be compatible with JRegistry::bindData(&$parent, $data) in /home/warcho1/public_html/components/com_jlinked/libraries/jlinkeddata.php on line 422

Strict Standards: Declaration of JCacheControllerPage::store() should be compatible with JCacheController::store($data, $id, $group = NULL) in /home/warcho1/public_html/libraries/joomla/cache/controller/page.php on line 199


Error 404

(Component not found)


Please try one of the following pages:
Last edit: 7 years 9 months ago by warchop.
The topic has been locked.
Support Specialist
7 years 9 months ago #41507 by alzander
Replied by alzander on topic 500 Errors Post V6 Upgrade
JFBConnect v6.0 integrates the features of JLinked into it. If you installed JFBConnect v6.0, you should disable JLinked and perform a migration of your settings to JFBConnect.

If you're using JFBConnect v5.2.2 and JLinked v2, then we'd need to investigate more and could probably help get you going. However, we'd recommend upgrading to JFBConnect v6.0 if possible.

Let me know if that helps, but should you have any questions or issues, let me know.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
7 years 9 months ago #41514 by warchop
Replied by warchop on topic 500 Errors Post V6 Upgrade
Have the issue sorted out...many thanks!

Next issue is I am unable to configure JFBC Connect in administration.

File Attachment:


The radio boxes are no longer there. Kindly request advise.
The topic has been locked.
Support Specialist
7 years 9 months ago #41518 by alzander
Replied by alzander on topic 500 Errors Post V6 Upgrade
Please clear your browser cache and Joomla cache and logout of the Joomla admin area.

When you log back in, things should hopefully work for you. Your site likely is loading an older version of our Javascript and CSS.

If that doesn't work, just let us know.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
7 years 9 months ago #41519 by warchop
Replied by warchop on topic 500 Errors Post V6 Upgrade
Alex:

Tried that...did not work :(

The images associated with the login are not loading as well.

Warm regards,

Scott
The topic has been locked.
Support Specialist
7 years 9 months ago #41543 by alzander
Replied by alzander on topic 500 Errors Post V6 Upgrade
Scott,
If the images for the login buttons didn't come in, it means there is likely a permissions issue on your server on one, or all, of the directories below:
/media/
/media/sourcecoast/
/media/sourcecoast/images/
/media/sourcecoast/images/provider
Each server is different, so I don't know what user ownership or permissions you'd need. If the media folder or our sourcecoast directory can't be written to with our CSS, image and Javascript files, it would make sense that admin area functionality and button images on the front (and likely other things you may not be aware of yet) aren't working.

Once you get the permissions setup right, simply re-install JFBConnect and the files should (hopefully) be copied right over.

Let me know if that helps, and good luck,
Alex
The topic has been locked.
Support Specialist
7 years 9 months ago #41554 by alzander
Replied by alzander on topic 500 Errors Post V6 Upgrade
Thanks for the PM with your admin credentials. Our media files were definitely not installed correctly. The following Javascript errors are showing in the JFBConnect configuration area:
Failed to load resource: the server responded with a status of 404 (Not Found) http://www.YOURSITE.com/media/sourcecoast/css/sc_bootstrap.css
Failed to load resource: the server responded with a status of 404 (Not Found) http://www.YOURSITE.com/media/sourcecoast/js/jq-bootstrap-1.8.3.js
Uncaught ReferenceError: jfbcJQuery is not defined jfbcadmin-template.js:52
Uncaught ReferenceError: jQuery is not defined jfbconnect-admin.js:7
I'm not sure why, but you'll need to investigate the issues noted above and try to determine what prevented our media files from installing/updating.

I hope that helps,
Alex
The topic has been locked.
Active Subscriptions:

None
7 years 9 months ago #41558 by warchop
Replied by warchop on topic 500 Errors Post V6 Upgrade
O.K. so cleared the images issue. Now I'm receiving 500 errors. I have redirect set to 'same page' so the issue should not be happening. Kindly request advise...I've searched on the forum here for an hour for the answer, the fixes posted here did not work. I've cleared cache.
The topic has been locked.
Support Specialist
7 years 9 months ago #41570 by alzander
Replied by alzander on topic 500 Errors Post V6 Upgrade
I just registered using Facebook, logged out, and logged back in. The registration and login portion worked fine. I was testing from the home page.

When I tried to logout, I did get a 500 error. Can you check the "Logout Redirection URL" in the SCLogin module and make sure it's correct. Even if it looks right, please try changing it to another menu item just to test a different setting and see how that works.

If you are still having issues, or other things aren't working, please tell me exactly what the 500 error is reporting.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
7 years 9 months ago #41586 by warchop
Replied by warchop on topic 500 Errors Post V6 Upgrade
Alex:

Tried changing the settings as you requested...still not working correctly. Please be aware that these issues were not present in the previous version..

I have to get this working...I can't expect my users to figure it out, I'm supposed to be rolling my site out soon, but I can't because of the login issue.

Warm regards,

Scott
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy