Black Friday / Cyber Monday Special - 10% Off - Use "CYBER10" at checkout!

Topic-icon Log in with LinkedIn not working anymore

Active Subscriptions:

None
8 years 4 weeks ago #38398 by pausta
Hi,
I tried several times today to log in with linkedin in my website (www.symradar.com). I cleared the cookies and cache of my browser but still it won't log me in.
Could you identify the problem?

Thank you.
The topic has been locked.
Active Subscriptions:

None
8 years 4 weeks ago #38399 by isbaltic

pausta wrote: Hi,
I tried several times today to log in with linkedin in my website (www.symradar.com). I cleared the cookies and cache of my browser but still it won't log me in.
Could you identify the problem?

Thank you.

just posting with this account too to verify that we have an active subscription
Thank you.
The topic has been locked.
Support Specialist
8 years 4 weeks ago #38403 by alzander
Paulos,
Something is preventing the normal redirection process for JLinked and LinkedIn. The place I'd start looking is in your SEF or translation extension. Try disabling one, or both, and test again to see if it works. Then, re-enable each on individually to narrow things down. If it's your SEF extension, see if you can have it 'skip' altering the URLs of JLinked.

I hope that helps get you started, but if not, let us know what you find with the tests above.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
8 years 3 weeks ago #38406 by pausta
Hi,
I tried disabling the plug-ins you said, one by one, and all combined but it didn't seem to work. It's very frustrating because up to 3 days ago everything was fine and the language selector was working in harmony with JLinked. How can we resolve this?
The topic has been locked.
Support Specialist
8 years 3 weeks ago #38408 by alzander
Paulos,
I'm not sure what's happening. JLinked hasn't changed in the last week (or month) as well, so it's not a change on our end. That leaves either LinkedIn, which is unlikely since we haven't heard of this issue from others, or a change in behavior on your site.

The only other thing I forgot to mention above was a possible caching issue. Can you disable caching in the Global Configuration area of Joomla and the System - Cache plugin, if enabled, and try one more time?

If that doesn't work, feel free to private message us some admin credentials and we'll gladly investigate further.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
8 years 3 weeks ago #38414 by pausta
All the caching were already disabled. I PMed you about the admin creds
The topic has been locked.
Support Specialist
8 years 3 weeks ago #38429 by alzander
Thanks for the admin credentials. In the admin area of JLinked, I enabled the "Display API Errors on Front-end" setting. Then, when logging in, I got the following message:

JLinked API Error: OAuth callback URL was not confirmed by the LinkedIn end-point (signature_invalid)
From:https://api.linkedin.com/uas/oauth/requestToken?scope=r_emailaddress

That indicates that there's a communication problem between your site and LinkedIn. That could be due to a change in your server's configuration (usually a firewall block) or something on-site, like an incorrect redirection. There's nothing I can see in your Joomla configuration that would be causing issues. I tried to disable Joomfish as much as I could (though disabling all 4 system plugins resulted in a redirect loop for some reason).

The best thing I'd recommend now is contacting your hosting provider and making sure that your server is able to communicate with the following URL:

api.linkedin.com/

Since nothing has changed on your site, LinkedIn, or JLinked to cause this, the only thing left is that your hosting provider changed a configuration setting somewhere.

Hopefully, they'll be able to help verify that there is no blockage to that URL, or outgoing requests in general, from your server. We'll gladly help investigating further, but there's not much I can do at this point.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
8 years 3 weeks ago #38437 by pausta
Hi,
I was told that the communication with that link is fine. There is nothing that could be blocking the api server or anything. I tried disabling the language menus/modules/items but still it doesn't work. I am running out of options.
I noticed something though. When i click on api.linkedin.com/ I get this error

"Page Not Found
The page you requested is no longer available, or cannot be found.
Please double-check the URL (address) you used, or contact us if you feel you have reached this page in error.
Click the “Back” button on your browser or go to the home page."

And i tried from several computers. But then again if that was the problem, then a lot of people would have reported it.
It's very frustrating
The topic has been locked.
Support Specialist
8 years 3 weeks ago #38466 by alzander
Alright.. things seem to be working again. The problem is that your server time has drifted and is no longer accurate. For security purposes, LinkedIn rejects requests that are sent more than 15 minutes off of 'real time'. Your server just entered this boundary, and that's where the failures we're coming from. JLinked actually has a built-in correction for this, but it relies on LinkedIn returning a specific error stating that the Timestamp is incorrect. It seems like there's a bug with LinkedIn where, if you're pretty much exactly 15 minutes incorrect, they just fail the request but don't let us (JLinked) know why.. which prevents our auto-correction.

There were no code changes to JLinked required, just a 'force' of our timestamp correction to fix things. I'd recommend using a tool on your server to keep the Timestamp in up to date. There are many tools to do this, or your host should already be doing it.

Finally, I disabled the User - Contact Creator plugin as it was preventing me from deleting users and re-registering. Feel free to re-enable it if you need it, or disable it for testing purposes.

I hope that helps,
Alex
The topic has been locked.
Active Subscriptions:

None
8 years 3 weeks ago #38483 by pausta
Alright!! Thanks a lot again Alex. Its been very frustrating to find out what was causing the problem and I am glad that you found it. I will let my host know about this issue.

Thank you,
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy