Black Friday / Cyber Monday Special - 10% Off - Use "CYBER10" at checkout!

Topic-icon Apply with Linked in nolonger working

Active Subscriptions:

None
8 years 1 month ago #38154 by flux3
I previously had Jlinked and "apply with linkedin" working just fine. I recently re-uploaded the website after some issues and tweaks (to content and modules but not the sourcecoast stuff) and now I cant get it working for the life of me.
My "log-in with Linkedin" works OK so i guess that means the API key is still good but when i click on an "Apply with linked in" link i get a modal with the message "There was an unexpected problem that prevented us from completing your request."
The website is at www.foxwellassociates.co.uk

Hope you can help.... If you need super admin access to backend let me know.
The topic has been locked.
Support Specialist
8 years 1 month ago #38161 by alzander
Your whole site is showing the following error to me:

403 - You've got to ask yourself one question: Do I feel lucky?

Not sure if I need to be logged in somehow or if your site is offline.

Either way, the problem is likely your LinkedIn Application Setup. Specifically, the "Javascript API Domain". That needs to be set properly for your site and would prevent some of the social modules from failing if incorrect. The login functionality doesn't use the Javascript Domain setting, so it may still work even if other features don't.

For your site, the API domain setting should probably be:

www.foxwellassociates.co.uk/,http://foxwellassociates.co.uk/


I hope that helps,
Alex
The topic has been locked.
Active Subscriptions:

None
8 years 1 month ago #38163 by flux3
What a dunce, i had a major attack yesterday from a huge array of IP addresses so I geographically blocked most other countries other than UK and USA until they moved on to another victim. I should have unset that before asking you to take a look. Sorry.
With regards to your reply, i'll take a look but, like i said, it was working perfectly before. I shall delve deeper and see what i can find. Thank you
The topic has been locked.
Active Subscriptions:

None
8 years 1 month ago #38164 by flux3
I have checked the Linkedin Application details but still no joy. I have used the domain both with and without www. (one is redirected to the other anyway). Do I need to add port numbers? Not sure if there is a propagation time but i've left it an hour or so.
The topic has been locked.
Support Specialist
8 years 1 month ago #38168 by alzander
How are you adding that Apply button? Are you using the {JLinkedApply .. } tag? If so, can you update the phone=true to phone=required. Alternatively, disable the Require Phone setting and test that way?

In short, I tested and investigated a lot. The only thing different between the code on your site and what LinkedIn currently recommends is the true value for that phone setting.. so I'd start there.

I hope that helps,
Alex
The topic has been locked.
Active Subscriptions:

None
8 years 1 month ago #38171 by flux3
You are a star.
The phone=required change was the solution thank you so much.
The topic has been locked.
Support Specialist
8 years 1 month ago #38181 by alzander
Awesome! Glad to hear that got you going. I'm assuming you were using the {JLinkedApply .. } tag then, correct? We'll update our documentation accordingly.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
8 years 1 month ago #38187 by flux3
Yes that is correct, I am using the {JlinkedApply} tag. Thanks again
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy