Topic-icon Upgraded to JFBC 4.3.2 OK; upgrade of JLinked to v1.4 causes errors

Active Subscriptions:

None
Current Joomla version is 2.5.6, we just upgraded JFBC to the latest version and ran autotune with no issues...all green. Subsequent upgrade of JLinked yields a 500 server error when accessing the admin console. The front end displays a "login screen" now after the JLinked update, too. Attached are screen snips of the before & after configurations of the component, as well as the displayed errors. cURL is enabled ok. Everything works correctly after the JFBC upgrade without the JLinked upgrade, but upgrading JLinked to v1.4 is causing problems. Thanks in advance!
File Attachment:
File Attachment:
File Attachment:
File Attachment:
The topic has been locked.
Support Specialist
Re-install JFBConnect again. I think there were some changes in the shared library we use between the 2 extensions and JFBConnect has the latest copy. You can also use the Joomla Update Manager to upgrade just the library, which should work as well.

If that doesn't help, let us know, and we'll help look into the matter further.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
Re-installed a fresh download of JFBC. Still getting the same errors as outlined earlier when trying to upgrade JLinked...tried to upgrade JLinked using a fresh download as well as using the mechanism within the JLinked component. Here is something that may/not be relevant...when running the autotune in JFBC, the Error Check mechanism isn't recognizing my recent subscription renewal for JFBC for some reason (see attached snip). (
File Attachment:

NOTE: I took advantage of the special promotion you were running during the Joomla conference, fyi)
The topic has been locked.
Support Specialist
Hrmm. Not sure why Autotune wouldn't work, but that shouldn't have anything to do with your errors. We in no way 'explode' our extensions if you don't have a subscription. We'll look into that and hopefully get that fixed in the next day or so, but it's not the issue.

Can you go to the Joomla Installer area and the "Manage" tab. Use the filter and search for "SourceCoast". The version should be v1.0.9, I believe, but post whatever you have. Either way, go to the Update tab and purge cache and then hit Refresh. If the SourceCoast Library shows up there, update it.

Finally, one last thing to try.. go to the Joomla Global config and set Error Reporting to "Maximum" and turn GZip compression Off. Then, recreate the 500 error. Hopefully, there will be a prettier PHP message that will help us narrow down what's going wrong.

We'll be testing more with both versions and seeing if we can recreate it, but your feedback will help a lot.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
Following your prev instructions, verified the Library installed is v1.0.9...went ahead and purged/refreshed cache with no resulting changes. Then, set Error Reporting to "Maximum" and verified GZip was turned off.

With the latest JFBC 4.3.2 already installed and before another attempt to upgrade JLinked from 1.3 to 1.4, I noticed that versions of the library in the below snip seemed odd...maybe this is an issue, maybe not..?
File Attachment:


Next, attempted to update JLinked to v1.4 via the component and received an error message "unable to open archive...cannot extract package...please update manually". After manually uploading/installing via the extension Manager, the following error resulted:
File Attachment:


For grins, then did a manual reinstall of JFBC4.3.2 via the extension Manager. The following 2 snips show the component status after the reinstall as well as what now is displayed on the frontend url.
File Attachment:

File Attachment:


Lastly, was still unable to run the Autotune since the component could not validate my latest subscription, fyi.

Hope this helps!
Thanks.
The topic has been locked.
Support Specialist
Thanks for all the info. Just to make sure we got it straight, everything seems to be working now, except for Autotune, correct? Still not good, but that shouldn't prevent any functionality from working.

As for Autotune, the error you're getting is very confusing. We tried your Subscriber ID on some of our development sites, and it worked fine. The status bar at the bottom of your image shows it's correctly seeing your subscription. Our system is also logging that your request was valid. So, something funky is happening, but I'm not sure where.

Can you go to the FB App page of Autotune and then hit the "Refresh" button? Let us know what messages you get in the system bar there? The notice or error message will help us diagnose what's going on a little more.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
No, nothing has been remedied. Per your instructions in coversation #4 of this thread, I posted snips in #5 after setting error reporting to "maximum" and making sure GZip compression was turned off. You'll see the resulting front & backend errors in the snips that you were wanting to see. In summary, we're running the latest JFBC 4.3.2 and JLinked 1.3 with no issues; when upgrading to JLinked 1.4, we get the resulting errors shown in the snips in thread #5. above.

As for the issue of Autotune not recognizing our current subscription, it shows no issues throughout each step of the autotune process UNTIL we reach the "remote error checking" step. The snip below has the issues highlighted in yellow. Thanks.
File Attachment:
The topic has been locked.
Support Specialist
Sorry for the mis-understanding. Your last pictures from your previous post show the front-page with a lot of warnings and notices, but from what I could see, none of them were from JFBConnect or our plugins. I thought from that that you weren't getting 500 errors anymore. I don't think there's anything we can do about those notices/warnings unless any of them are caused by JFBConnect or JLinked.

As for your current issue, if you're still having 500 errors on logging in, do the following:
* Upgrade JLinked to the latest version
* Re-install JFBConnect v4.3.2, even if that's already the version you're using
* Go to the Joomla Installer -> Update area. Hit the "Purge Cache" and then "Refresh" button.
* If there are any SourceCoast extensions that need to be updated, update them.

I think the problem is still the ordering of what your doing. JFBConnect was more recently released. There are some shared PHP code between the two, and while we tested thoroughly, it's possible there's something we missed with some changes in JFBConnect that aren't working if you're using the 'older' version of JLinked. So, install JLinked and then don't touch it. Update JFBConnect or anything else and hopefully that will get you going.

If that doesn't work, let us know. I'll probably ask you to send me admin credentials to your site, if that's ok, so we can investigate further and get you going quicker than a back-and-forth on the forums.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
Alex --

Followed your instructions outlined in #8 of this thread. After upgrading JLinked to v1.4 then reinstalling JFBC4.3.2 again, there still seems to be issues. Note that the snip below still shows a discrepancy with the library after following your steps. Also still, when then running Autotune no issues are shown until the final "error checking" step, where my current subscription is not being recognized by the system.
File Attachment:


After doing the above steps, we've reverted the VM back to the point where JFBC4.3.2 and JLinked1.3 are the current versions. I'll go ahead and PM you the login credentials to the admin console and will also send my Sourcecoast login & PW, too. We have backup and snapshots of the VM saved should we need to revert after you get in there, so no worries.

Thanks!
The topic has been locked.
Support Specialist
Wanted to get back to you on this to let you know we haven't forgotten about you. I didn't get to test the upgrade process tonight. Will definitely be doing that tomorrow to see if we can figure out where the issue is coming from.

I did get to see the problem you were having with Autotune. The issue is that you look to have changed your password on this site. When you do that, it changes your Subscriber ID. I updated the Subscriber ID in JFBConnect, and Autotune Error Check properly runs now (you have no issues). The FB App section can't run since your firewall seems to be preventing outbound connections to SourceCoast.com, which is also preventing the auto-updater from checking for, or updating to, a new release.

I'll keep you posted on what I find tomorrow, and hopefully we'll get you going soon.

Thanks,
Alex
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy