Jomsocial- JFBC- Opengraph issue

Jomsocial- JFBC- Opengraph issue

Im testing the opengraph functionality with the jomsocial, and when i successfully trigger the action (upload) object (photo) in the facebook test account and in the admin account it shows this:
-
Donna uploaded SITENAME OR APP NAME  at APPNAME.
instead of
Donna uploaded a photo at APPNAME
-
Also when i click the "APPNAME" at the end of the post  in the ACTIVITY BOX it redirects me to the app in facebook  saying:
Secure browsing is not supported
This application does not yet support secure browsing (HTTPS).
Update secure URL
-
I dont have an ssl and dont have on my plans to buy one. ( i would prefer to have the last link back to the site)

SCREENSHOT:
http://www.sourcecoast.com/components/com_agora/img/members/447/forum.jpg
i've think i explained well my issue, with screenshots and all hehe now tell me what im doing wrong  current/big_smile

Kalastromake
Chris
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Jomsocial- JFBC- Opengraph issue

Please go into your Facebook Developer area for your app where you can change the configuration settings. Click on "Edit Settings" and then find the "App on Facebook" toward the bottom. Hit the 'X' in the top right corner of that section, deleting your settings. Then save (sometimes, it takes 2 to 3 times to save, due to a bug on Facebook's part).

That should fix the link and may fix the overall link text as well.

Right now, our Autotune tool will always set your Canvas URL to make sure you can use all features. We're planning an update to Autotune to detect (or ask the admin) if SSL is functional on the site. If not, it will leave those settings blank.

Let us know how that goes,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Jomsocial- JFBC- Opengraph issue

Ok  im on it, will post my results asap! thx for your prompt answer!

Kalastromake
Chris
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Jomsocial- JFBC- Opengraph issue

@alzander  i removed the app as you instructed, it works;
now when i clickd on the link it goes directly to the site, Thanks!

but i tested the joomsocial, uploaded a picture and its showing the same as on the screenshot i posted.. any other tips?

Kalastromake
Chris
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Jomsocial- JFBC- Opengraph issue

Glad we're making progress.

Now, go to your Developer area in Facebook and edit the settings for your App. Go to Open Graph and then click into the Object you're working with (Photo or whatever). Click on the "Advanced" link in the middle of the page. Then, check the "Singular Noun:" and "Plural Noun:" settings to make sure they are Photo or whatever you'd want to display. That is likely the issue, but if that seems correct, let us know and we'll try to come up with more ideas.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Jomsocial- JFBC- Opengraph issue

http://www.sourcecoast.com/components/com_agora/img/members/447/support.jpg

its ok but still having the problem, any more suggestions?

Kalastromake
Chris
useravatar
Offline
6 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Jomsocial- JFBC- Opengraph issue

So your settings are correct. The only other thing I can think of is that there's an issue with the Open Graph tags on the page you're posting. Can you post (or Private message) me a link to a photo that's been uploaded so that we can see the HTML for the page and hopefully figure out what's going wrong?

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11607
Total Polls:
0
Total Posts:
48788
Posts today:
11
User Info
 
Total Users:
47655
Newest User:
jayilu
Members Online:
0
Guests Online:
848

Online: 
There are no members online
Social Stream
SourceCoast Joomla Social Extensions
Friday, 25 May 2018
JFBConnect 8.0 Coming Soon! Stay tuned.
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program