why no reply for private message AGAIN?

Re: why no reply for private message AGAIN?

I just investigated further as to what's happening.

When JFBConnect tries to autopost content, we make a call to the front-end of the site to get the SEF version of the URL to be posted. However, that call is failing when being made from the admin area of your site.

When that call is made, it makes a request like:
index.php?option=com_jfbconnect&task=ajax.sef&url=aW5kZXgucGhwP29wdGlvbj1jb21fZWFzeWJsb2cmdmlldz1lbnRyeSZpZD05ODU=

If I go to that URL directly, it works. From the admin area making the call, it fails with the following error:

Forbidden

You don't have permission to access /dev/index.php on this server.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I'm not sure what's causing that as it seems like it may be a firewall or other server configuration issue not allowing the admin area to call the front-end of your site. Because that call is failing, the URL was just being the relative link.

I've made a change on your site which should generate a working URL including the domain. Please test and let me know if that works for you.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24104 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: why no reply for private message AGAIN?

the non SEF link works in facebook post. I just installed latest ver of admintools, which may be blocking access to admin area. can you test the SEF link again? or even you can disable admin tool plugin for a while to test.

skyfranky
useravatar
Offline
69 Posts
Active Subscriptions:

Administrator has disabled public posting. Please login or register in order to proceed.

Re: why no reply for private message AGAIN?

The code change I made on your site will work if the Forbidden issue is fixed automatically. The change I made simply uses the non-SEF link if the SEF link couldn't be generated. So you are free to test and try disabling AdminTools or whatever else you think may be preventing the front-end page load to be working. If it still fails, you'll get a non-SEF URL which at least works.

I plan to have this code fix implemented in the next release as well.

I hope that helps explain,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24104 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: why no reply for private message AGAIN?

I do not see any new ver download as you said you will release.

skyfranky
useravatar
Offline
69 Posts
Active Subscriptions:

Administrator has disabled public posting. Please login or register in order to proceed.

Re: why no reply for private message AGAIN?

The code change we put on your site is checked in, but we haven't released an updated version with it included yet. Your site was the only issue with this problem so far, and your site should be fixed for now. We are working on a new release which has this, along with other fixes for other users and various improvements, that should be out over the next few weeks.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24104 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: why no reply for private message AGAIN?

I need to copy the files to my live site and test. what files should I copy?

skyfranky
useravatar
Offline
69 Posts
Active Subscriptions:

Administrator has disabled public posting. Please login or register in order to proceed.

Re: why no reply for private message AGAIN?

Looking at what's checked in, it should be in /libraries/sourcecoast/openGraphPlugin.php

Want to stay up-to-date on new releases and development efforts?
Follow us on Twitter @sourcecoast and @mandreae

mel
Melissa
useravatar
Offline
3603 Posts
Website 
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: why no reply for private message AGAIN?

alzander wrote:


I just investigated further as to what's happening.

When JFBConnect tries to autopost content, we make a call to the front-end of the site to get the SEF version of the URL to be posted. However, that call is failing when being made from the admin area of your site.

When that call is made, it makes a request like:
index.php?option=com_jfbconnect&task=ajax.sef&url=aW5kZXgucGhwP29wdGlvbj1jb21fZWFzeWJsb2cmdmlldz1lbnRyeSZpZD05ODU=

If I go to that URL directly, it works. From the admin area making the call, it fails with the following error:

Forbidden

You don't have permission to access /dev/index.php on this server.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I'm not sure what's causing that as it seems like it may be a firewall or other server configuration issue not allowing the admin area to call the front-end of your site. Because that call is failing, the URL was just being the relative link.

I've made a change on your site which should generate a working URL including the domain. Please test and let me know if that works for you.

Thanks,
Alex

I can get the non-sef link working, but still don't know why SEF url not working. I tried to disable admintools to test, and SEF still not wroking. what else can I test to find out what causing SEF link not working?

skyfranky
useravatar
Offline
69 Posts
Active Subscriptions:

Administrator has disabled public posting. Please login or register in order to proceed.

Re: why no reply for private message AGAIN?

If the SEF link isn't working, it means that the site is still likely returning the 500 Forbidden error when we try to generate the pretty URL. As noted above:

The change I made simply uses the non-SEF link if the SEF link couldn't be generated.

So, it sounds like you copied the change properly. Unfortunately, I don't have any explanation for what's preventing the admin area of your site to make a request to the front-end of your site.

To understand what's wrong, the 500 Forbidden error means that something is blocking the request. That could be an Apache firewall, like mod_apache, or something within Joomla itself, like AdminTools. Either of those, or any other blocking software, usually can have a log enabled. You'll need to view the mod_apache or AdminTools or whatever other security features you have enabled to understand why the request is being blocked. Once you have that information, you should be able to whitelist the request or let us know the log details and we'll see if it's something we can work around in JFBConnect.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24104 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11667
Total Polls:
0
Total Posts:
48986
Posts today:
1
User Info
 
Total Users:
47792
Newest User:
romjat
Members Online:
0
Guests Online:
760

Online: 
There are no members online
Social Stream
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program