Forum is closed

Facebook problems last few days?

Facebook problems last few days?

The last 2-3 days I've missed a number of comments on our site. I've checked with the web host, and they swear it's nothing to do with them. Usually I get notified immediately about new likes and comments. But now, sometimes I don't get notified at all, which is a big problem...

For instance, the comment by Fritz Petter Hansen on http://www.thailandstidende.com/compone … ostitusjon - it never got to my attention. Just an example.

...?

Best regards

dageke
Dag
useravatar
Offline
85 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

Dag,
I'm not sure what would be causing that. Are other comments on the same page properly sending you a notification? If it seems to be from a specific page, that would definitely help narrow things down.

Other things to check/test are:
* Try leaving a comment on a page with both www. and no www and make sure both properly send the notification
* Check your PHP error logs on the server to see if there are any errors posted there

Let me know if either of those helps narrow things down. We'll help how we can, but haven't heard of that problem.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

Alex, thanks for the reply.

The problem is not confined to a specific page. I’ve now checked a number of pages. Interestingly, re. the URL I gave you first, I actually did get notification of all four comments, but the last one arrived late (something like 24 hours after the comment was made)

I got notification for 7 of the 9 comments on this page:
http://www.thailandstidende.com/compone … i-thailand

I got notification for 3 of the 5 comments on this page:
http://www.thailandstidende.com/compone … om-pattaya

I made two comments on this page, one without the www in the URL. I got notification only from the URL without www.
http://thailandstidende.com/component/k … orsk-skole

Then I made a comment on this page, and got no notification
http://www.thailandstidende.com/compone … arder-baht

Then I tried without the www on this page, and also got no notification.
http://thailandstidende.com/component/k … -lorenskog

I left these comments there for about one hour… . I think almost all people access our pages with the www included in the URL, so I don’t think that is the problem here (could be wrong, of course).

Re. my testing of the system, perhaps the system is reluctant about giving notification when the comment is made by the administrator…? Maybe you can try to comment, Alex.

Re. Likes, I only got 2 notifications of Likes on this page, but the page shows 86 Likes. It’s not critical to be notified about Likes, but it’s a bit strange that I only got two…
http://www.thailandstidende.com/compone … i-thailand

Edited by: alzander - Nov-05-13 18:23:55
dageke
Dag
useravatar
Offline
85 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

The log you included was the Apache error log, not the PHP one.. so I removed it from the post. The PHP log isn't important given the information you provided.

the URL I gave you first, I actually did get notification of all four comments, but the last one arrived late (something like 24 hours after the comment was made)

This is key. Facebook notifies JFBConnect of the new comment immediately right after it's posted. It's done through Javascript on the page and triggered in the same request after the user hits the "Post Comment" button.

Therefore, if you're not seeing the comment for 24 hours (or however long) after it was posted, it likely means there's an issue with your email server. The emails could be going into a spam box, never being delivered, or something else like that. JFBConnect would not be able to send an email even 2 minutes after the post, so if there's a delay, it's from somewhere else.

What I'd recommend is to add a new email address for the notification of comments/likes. You can add multiple comma-separated emails there, like:

Please note, it's comma-separated with no spaces. I'd recommend trying to add some other email address on a different domain (so that the same filters/issues won't affect it) and see if you get more (or quicker) messages at that other email.

I hope that helps narrow things down.. but definitely test and let me know how it goes.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

Hi, the component was set to notify a thailandstidende.com email address (which automatically forwards to my Gmail address). Now, I’ve change it so that the notifications are sent directly to my Gmail address, which would eliminate one clog in the chain. Except, the problem seems to originate with Gmail. (Have you encountered problems with Gmail?)

Me and a friend have been commenting on several pages all morning.

I’m being notified about the first (of first few) comments (on any page). Then, it looks like Gmail will stop letting these emails through, and I’m not notified anymore. Then, if I wait some time (perhaps an hour or more), and start commenting again, I’m notified, but the comments that were made in the meantime never gets notified.

Seems like Gmail just throws these notifications away if there are too many in a short time frame.

At the outset, I created a filter in Gmail instructing the system not to send to spam anything from our forum (defined by the sender, which is [email protected]), but that didn’t seem to help. The Spam folder is empty, anyway.

I get a message from Gmail each time saying “This message was not sent to Spam because of a filter you created”.

Do I need to change to something other than Gmail in order for this to work? That would be a drag. Have you encountered these kinds of problems before?

dageke
Dag
useravatar
Offline
85 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

... meant to say:

"I’m being notified about the first (OR first few)

dageke
Dag
useravatar
Offline
85 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

We haven't heard of anything with Gmail being the issue. They do have multiple levels of spam filters.. there are some filters that delete mail before it ever even hits your 'real' spam folder because there's no doubt it's spam/phishing, etc. I can't imagine the notification email is hitting that threshold though.

The only thing I can suggest, if possible, is trying to add another email to send the notification to.. hotmail, yahoo, personal account, etc. Then, you can compare both accounts to see if they both stop receiving the notification at the exact same point or if they are each getting separate results. That would narrow down if it's a filter/issue on the receiving end (your inbox) or a problem in JFBConnect (mail never being triggered) or your server (not sending the mail).

The last question I have, though I think I know the answer, is whether you're reloading the page between comments. Since this is happening for other users, I'm assuming it doesn't matter. If you are testing by just making comment after comment on the same page without reloading, that's not terribly realistic. That shouldn't be a problem, but best to test in a realistic way, if you aren't.

Finally, from here, we can help you add some logging. It's a few lines of code in one of our files that would write to a file on your server each time a notification email should be sent. From there, we'd narrow things down further as to where the problem is.

I hope that helps,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

The problem is not with Gmail. I registered for notifications to be send to my Yahoo address as well as Gmail, and the problem is the same.

A few minutes ago, I wrote a comment below this article:
http://www.thailandstidende.com/compone … orsk-skole
(I’ve deleted it now). I got the notification right away (both on Gmail and Yahoo).

Then, I waited a few minutes and wrote a comment on this article:
http://www.thailandstidende.com/compone … -lorenskog
And… Nothing. No notification on either email address.

Seems the system will not send out two notifications in a row when the time span between them is short.

The web host has looked at the logs and claims there are no problems with our site.

I think I need help with the logging you suggested…

Best regards

dageke
Dag
useravatar
Offline
85 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

Just checking that you saw my latest post (I never get notifications from this forum...)

dageke
Dag
useravatar
Offline
85 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

Dag,
Sorry for the delay. We did get your last post and are trying to setup some tests of our own. I'll also get you the logging code soon, but it's honestly something I have to look up for Joomla 1.5 as things are a lot different for that version of Joomla, and I'm not as familiar with it anymore.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

So, I keep checking this thread daily (because your notification does not work). Let me just ask you some questions:

Our developer has quit. How long can I rely on using 1.5 before I upgrade? (It’s working fine for our needs).

The developer said it was a big job to upgrade to 2.5. Is this true, in general?

dageke
Dag
useravatar
Offline
85 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

Dag,
I've tried to 'force' a subscription for your account to this thread. Hopefully, you'll get the email after I post this, and future emails.

For the logging, please edit the /components/com_jfbconnect/controllers/social.php file. In there, you'll find a "commentCreate" function around line 20. Please update that whole function with the following code:

Code:

    function commentCreate()

    {
jimport('joomla.error.log');
$log = &JLog::getInstance('com_jfbconnect.comments.log.php');
$log->addEntry(array('comment' => 'New comment detected');
        $jfbcLibrary = JFBConnectFacebookLibrary::getInstance();
        $configModel = $jfbcLibrary->getConfigModel();

        $href = JRequest::getVar('href');
        $href = urldecode($href);

        $title = JRequest::getVar('title');
$log->addEntry(array('comment' => 'URL: ' . $href . ', title: ' . $title);

        // Assign alpha user points, if enabled
        $this->rewardAlphaUserPoints($configModel->getSetting('social_alphauserpoints_enabled'), $href, 'comment');

        // Check if admin email should be sent
        if (!$configModel->getSetting('social_notification_comment_enabled'))
{
$log->addEntry(array('comment' => 'Comment notifications are disabled!');
            exit;
}
        //$commentId = JRequest::getVar('commentID');
        // Comment is too unreliable to get immediately (almost never there), so not including it in email for now
        //$comment = $jfbcLibrary->api('/comments/?ids='.urlencode($href));

        $subject = JText::_('COM_JFBCONNECT_NEW_COMMENT_SUBJECT');
        $body = JText::sprintf('COM_JFBCONNECT_NEW_COMMENT_BODY', $this->getPoster(), $title, $href);
$log->addEntry(array('comment' => 'Sending email');

        $this->_sendEmail($subject, $body);
        exit;
    }

All the new changes don't have spaces in the front, so you can either copy each change or copy the whole block of code.

That should create a /log/com_jfbconnect.comment.log.php file and push a lot of information into it for each comment, like:

New comment detected
URL: http://site.com/link, title: Title of article
Sending email

Each comment should generate those 3 strings. If they are generated, but an email isn't sent, it means that Joomla is likely having issues (though there's a little more logging we can add to verify that). If those lines aren't being generated, or only parts of them are, it means that our code isn't being called or completing for some reason.

Please test and let me know what happens. If the log isn't generated or doesn't have anything, it means that the code above may have a bug and we'll need to re-test it.

Our developer has quit. How long can I rely on using 1.5 before I upgrade? (It’s working fine for our needs).
The developer said it was a big job to upgrade to 2.5. Is this true, in general?

That's a tough question. Joomla 1.5 is already past End of Life and is no longer being developed or even supported by Joomla.org. There was a security issue in Joomla 1.5.26 that was discovered late last year and only patched by the community (see here to get an unofficial patch). if other security issues are found, they may never be patched and it likely won't be as widely announced to make sure everyone knows to update.

The move to Joomla 2.5, unfortunately, can be difficult. It depends on the extensions and features of Joomla you're using. There are migration tools that make things easier, but they usually don't do everything. For JFBConnect, you simply need to copy over a few database tables from your Joomla 1.5 site to Joomla 2.5 and the install the Joomla 2.5 version. Other extensions aren't as simple.

Fortunately, the move from Joomla 2.5 to 3.x (and the plan for 3.5 to 4.x) is much simpler. It usually a few hour process, including testing, for good developers if your extensions are supported.

So, I would recommend moving off of Joomla 1.5, but that's a much easier statement to make rather than do.

I hope that helps explain, but if you have any questions, just let me know.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

Thanks, Alex. I will test this out.

Now, I’ve noticed one other disturbing thing (If this is also an issue limited to 1.5, I need to upgrade for sure). Hopefully this is something you can easily answer:

When I’m making a comment and check the box “Publish on Facebook” (at least that’s what mine says -- in Norwegian), the comment does NOT appear on my Facebook timeline. How can this be?

(And, yes, I got the notification this time.)

Regards
Dag

dageke
Dag
useravatar
Offline
85 Posts
Active Subscriptions:

None
Administrator has disabled public posting. Please login or register in order to proceed.

Re: Facebook problems last few days?

Keep me posted on the logging change. I'd love to hear the results to better understand where the problem is.

When I’m making a comment and check the box “Publish on Facebook” (at least that’s what mine says -- in Norwegian), the comment does NOT appear on my Facebook timeline. How can this be?

This seems to be like an issue with Facebook. We heard a separate report that the Like button (which has a comment box popup) isn't properly posting to Facebook either when used. We're looking into it right now.

In general though, the "Post to Facebook" box is something we have no control over. If it's not working, it wouldn't work on Joomla 2.5+ either. If the problem sticks around for more than 24 hours or so, let us know. I just check the Facebook bug report area and this doesn't seem to have been reported. If you still have the problem though, we'll gladly test ourselves and help you fill out a bug report, if necessary.

Thanks,
Alex

If you use our extensions, please consider leaving a rating and review at the Joomla! Extension Directory:
JFBConnect | SCLogin

alzander
Alex
useravatar
Offline
24009 Posts
Support Specialist
Administrator has disabled public posting. Please login or register in order to proceed.
There are 0 guests also viewing this topic
There are 0 users also viewing this topic

Board Info

Board Stats
 
Total Topics:
11607
Total Polls:
0
Total Posts:
48788
Posts today:
11
User Info
 
Total Users:
47656
Newest User:
vulawoffice
Members Online:
2
Guests Online:
467

Social Stream
SourceCoast Joomla Social Extensions
Friday, 25 May 2018
JFBConnect 8.0 Coming Soon! Stay tuned.
Refer and Earn

Like our extensions? You're not alone! That's why they're used on tens of thousands of websites. Now you can earn 20% of any sale you refer to SourceCoast.com.

We provide excellent documentation, well laid out sales pages and great support. All you need to do is spread the word and we'll take care of the rest.

Learn About Our Affiliate Program