Topic-icon Randomly sending me to connect FB with your account page

Active Subscriptions:

None
I have spent pretty much all of yesterday configuring this wondrous component and for the most part it is working well, i do have two issues though.

1. From time to time and without any interaction the page just reloads to the "Thanks for signing in using Facebook,If you already have an account, just log in here, and we'll link your Facebook account to it." page with all of the fields that are required in that registration process. This would be great had I actually clicked to register but i was merely browsing another page. This has happened several times now so it wasn't a accidental click. Do you have any idea what might cause this? I am logged into FB in another tab.
If it helps, the page im redirected to is www.mysite.co.uk/index.php?option=com_jf...xlongalphanumericxxx

2. After much setting up of Open graph it still keeps using the default image (as set in the configuration page) rather than the image set in the shortcode . It works fine in articles that use the content plugin but not when i use the shortcode to have specific images for certain pages.

You help would be much appreciated. The site is at www.myggp.co.uk
The topic has been locked.
Support Specialist

1. From time to time and without any interaction the page just reloads to the "Thanks for signing in using Facebook,If you already have an account, just log in here, and we'll link your Facebook account to it." page with all of the fields that are required in that registration process. This would be great had I actually clicked to register but i was merely browsing another page. This has happened several times now so it wasn't a accidental click. Do you have any idea what might cause this? I am logged into FB in another tab.

The only scenario I can think of that would cause that is under the following circumstances:
a) Your Facebook account that you're logged in with has previously approved the FB Application used on your site.
b) That Facebook account is not linked to any Joomla user on the site though (you never went through the registration process)
c) You have "Automatically Log Facebook Users In" enabled
With that configuration, if you're on your site and then don't click anything for 20 minutes (or whatever the Session Timeout is set to in the Joomla Global Configuration area), when you click next, JFBConnect will think you're returning to the site for the first time in 'a while'. Facebook will notify JFBConnect that a returning user has come back and we'll try to log you in. Since you don't have an account (b), we send you to the registration page.

That's an uncommon scenario since most user's would create an account, but it can happen. I hope that explains the situation, but if that doesn't seem right, let me know.

2. After much setting up of Open graph it still keeps using the default image (as set in the configuration page) rather than the image set in the shortcode . It works fine in articles that use the content plugin but not when i use the shortcode to have specific images for certain pages.

Can you let me know a specific page where you've set a short-code and what the exact code you used to set it? We'll gladly investigate.

The upcoming v6.0 release will have an Open Graph debug tool built in that will show you exactly how the Open Graph tags are determined for a page, which should help diagnose these issues as well. That release will be out sometime over the next week.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
7 years 11 months ago - 7 years 11 months ago #41223 by flux3
HI thanks for your timely response as usual

1. I have looked into this further and now i understand better how it works. You were correct in that I had deleted the account it was trying to connect. My problem now is that when you register a normal account, then click the activation link in the email it does indeed show a popup saying you are being logged in with your Facebook credentials but I think you should have the option wether you want it to or not as a user, ie. the popup says "We detect you are logged into Facebook, would you like to link these accounts? Linking the account will use your Facebook avatar.. blah blah blah". Either that or there be some way the user can unlink the account from Facebook.

2. Here is a link to an example page
myggp.co.uk/index.php?option=com_content...catid=111&Itemid=101
and the code im using is
SCOpenGraph description=<?php echo $cck->getValue ('dj_biography2'); ?> image=http://myggp.co.uk/<?php echo $cck->getValue ('dj_photo2'); ?> title=Checkout <?php echo $cck->getValue ('art_title2'); ?> at MyGGP.co.uk
(i have removed the curley braces to see if your forum will stop stripping out the code)
Im using Seblod so the $cck->getValue ('dj_photo2'); would return images/foldernme/imagename.jpg (this works, iv tested its returning the correct url). All of the ohter fields work a treat, just not the image.
Oh and i have ensured the specified image is >200px wide as mentioned on the FB OG test tool.
Last edit: 7 years 11 months ago by flux3.
The topic has been locked.
Support Specialist
1) You can disable the Automatically Login Facebook Users setting in the JFBConnect -> Configuration area if you don't like the current behavior. We are planning an option for letting users unlink their accounts from the front-end in a future release.

2) The tags can only set one Open Graph value at a time. You'd want to break the code you created up into different parts, like:
SCOpenGraph description=<?php echo $cck->getValue ('dj_biography2'); ?>
SCOpenGraph image=http://myggp.co.uk/<?php echo $cck->getValue ('dj_photo2'); ?>
SCOpenGraph title=Checkout <?php echo $cck->getValue ('art_title2'); ?> at MyGGP.co.uk
Please make sure you're using the { } marks around each line above too.

I hope that helps explain, but if you have other questions, just let me know.

Thanks,
Alex
The topic has been locked.
Active Subscriptions:

None
7 years 11 months ago #41242 by flux3
Wow that's dedication, answering support questions at the weekend. :D
1. I have now switched it off which is a shame as its a nice feature but the user does deserve a choice so i'll switch it back on when there is the facility for them to disconnect it.
2. You are a star, that is exactly what the problem was. Glad I can move on from Open Graph now.

Thank you so much for an outstanding product and even better support.
The topic has been locked.
Support Specialist

1. I have now switched it off which is a shame as its a nice feature but the user does deserve a choice so i'll switch it back on when there is the facility for them to disconnect it.

The option will be available later this year, but I don't have a timeframe for when. As for the auto-login feature in general, it shouldn't be making a connection between a Facebook account and a 'random' user on your site. Generally, if a user has logged in using Facebook, they have an account on your site, and would be logged into that. It's only in the case where a) they didn't register an account or b) you deleted that Joomla account that the auto-login may have some unwanted results. Those are not common situations though.. but disabling the feature definitely gets you around those problems.

Glad to hear we could help get you going in general. Should you need anything else, just let me know!

Finally, if you haven't already, please consider leaving a rating and review for JFBConnect, or our support, on the Joomla Extension Directory. It certainly isn't required, but is very appreciated:
extensions.joomla.org/extensions/social-...ook-integration/7215

Thanks,
Alex
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy