Topic-icon Must click Facebook Login Button twice to login

Hi,

I recently upgraded the component and am noticing that I have to hit the Facebook login button twice to be logged in successfully.

I open the SC Enhanced Login form via a Login button, and then I click the Facebook Login button. This opens the Facebook login window and then closes since I'm logged in to Facebook. Then it does nothing / fails to redirect. If I then click the Facebook Login button again, it opens the Facebook window again, closes it, and then this time it redirects afterwards and successfully logs me in.

Here's a GIF that illustrates the process:



Any idea why I have to hit the Facebook button twice to get it to login? Help is much appreciated, thanks!
The topic has been locked.
Support Specialist
2 years 7 months ago #65846 by mel
Are you still having this problem? I just visited your site and created a user with FB credentials. I logged out and then subsequently tried to log in again. I only had to push the button once to be logged in correctly then.

-Melissa
The topic has been locked.
2 years 7 months ago #65847 by Hayward

mel wrote: Are you still having this problem? I just visited your site and created a user with FB credentials. I logged out and then subsequently tried to log in again. I only had to push the button once to be logged in correctly then.

-Melissa


Yes, I am still having the issue with my own account.

I created an account manually through the site first, then performed the "link accounts" step (it is configured to match existing emails). I then I tried to login with Facebook and had to click it twice.
The topic has been locked.
Support Specialist
2 years 6 months ago #65850 by alzander
I just tested as well. When I click the Facebook button, the first time I was asked for normal Facebook permissions and was brought to the registration page right away. Trying again brings me right to the registration page on the first click.

Would it be possible to try a few things to help us narrow the possible causes down a bit?
* Can you try in a different browser?
* Can you try on a different computer altogether?
My only immediate guess is there is some tracking, advertising or malware blocker running on your computer that's detecting and blocking the first attempt. Some of those blockers will allow a 2nd attempt as they assume it's the actual intention.

Please test and let us know anything you can about how you're testing (browser, Mac/Win, etc) and we'll do whatever we can to help!

Thanks,
Alex
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Get the Hide and Seek Toy on Amazon