× Joomla Facebook Connect support forum

Topic-icon Button "Login with Facebook" doesn't show

Active Subscriptions:

None
7 years 5 months ago - 7 years 5 months ago #40267 by fabitas
Hi,
I installed JFBConnect and used it one day. When I log in with my Facebook profile I get "registered" status in Joomla! and I am able to see registered pages.
But on the second day, I was previously logged in to Facebook and I visited my website.
I saw my picture and it said "[my name] uses [my application]" but I didn't have registered status in Joomla! as if I wasn't logged in.
The "Login with Facebook" button doesn't appears. And I cannot also log out.
Only if I go to www.facebook.com and log out, then when I return to my site I see the button "Login with Facebook".
What is happening?
Thanks
My website is melton.huji.ac.il
Last edit: 7 years 5 months ago by fabitas.
The topic has been locked.
Support Specialist
7 years 5 months ago #40287 by alzander
That's an issue with the Javascript version of the Login with Facebook button itself when you have the "Show Faces" option enabled. You'll need to disable that setting as, when it's enabled and the user has already approved your app and is logged in, the login button won't show. You can see the notice of that issue below in the 'information box' in the first section:
developers.facebook.com/docs/reference/plugins/login/

Once you disable that, the login button should properly show. Alternatively, you could enable the "Automatically login Facebook users" setting in JFBConnect so that those users will be logged in when they return, and the login button won't be necessary.

I hope that helps,
Alex
The topic has been locked.
Active Subscriptions:

None
7 years 5 months ago - 7 years 5 months ago #40335 by fabitas
**UPDATE**
Sorry I have just found where to disable the option. I had to go to the Module Manager, find the SC Login Module and disable it from there.
Thanks, now it seems to be working ok.
*******

Hi, The alternative solution "Automatically login Facebook users" did not work for me, since it demands from visitors to create a user in Joomla! (and the login with Facebook button did not work).
So I want to disable the option "show faces" but I am not sure where exactly I am supposed to do that.
Could you guide me where is that option on JFBConnect?
Thanks for your help!
Fabian
Last edit: 7 years 5 months ago by fabitas.
The topic has been locked.
Active Subscriptions:

None
7 years 5 months ago - 7 years 5 months ago #40336 by fabitas
Fixed
Last edit: 7 years 5 months ago by fabitas.
The topic has been locked.
Support Specialist
7 years 5 months ago #40350 by alzander
Glad you found the solution. Should you have any other questions or issues, just let us know!

Thanks,
Alex
The topic has been locked.
Social Stream
Hide. Seek. Play!

Countdown Hide & Seek Game

Countdown, the new hide & seek toy, is available now! Designed and developed by the founders of SourceCoast, it's the perfect toy to get your kids moving at all ages.

Learn More About the Hide and Seek Toy